[mythtv-users] LiveTV browse across tuners, but no switch

David Kubicek foceni at gmail.com
Mon May 24 22:23:31 UTC 2010


since I've introduced MythTV to my family as an alternative to our
"old-school" setup, I'm being bombarded with complaints about
non-working channel surfing. :)

I've searched the web and found this issue bothers other people too. The
thing is that in LiveTV, when I browse available channels, those that
are available only on other (non-active) tuners cannot be switched to,
unless I change "inputs" via menu manually.

The bug is especially annoying when you have 3+ tuners and 5x multirec.
How is anybody supposed to know, which input to choose to find one that
has the particular multiplex free? There are e.g. 15 inputs, it's
impossible to try to explain this to my mother or, god forbid, visiting
grandma. :) Even I have to try two times sometimes!

If LiveTV code is unable to change tuners/inputs automatically, why even
allow browsing channels that don't work without manual intervention? I
really think this is a bug - I browse to a channel, make a switch, but
LiveTV switches to the same channel running previously. At the same
time, it seems to know which channels are available on which tuner,
because the browse list is reduced when a multiplex is "reserved".

This must be easy to fix, right? I even read somewhere that this was
going to be fixed in .22, but still no luck. It's really annoying the
hell out of me. :)

Any patches? Is it possible already? If not, I think I'm willing to
offer a *reward* to make this work. Recordings are all good, but nothing
beats LiveTV when it comes to LIVE TV...

David Kubicek

More information about the mythtv-users mailing list