[mythtv-users] Mysql permissions problem

Michael Tiller michael.tiller at gmail.com
Tue May 18 14:43:58 UTC 2010

OK, I solved it...

On Tue, May 18, 2010 at 8:49 AM, Peter Abplanalp <
pta-myth at psaconsultants.com> wrote:

> can you test from another host on your network? perhaps the mysql
> client is smart enough to figure out it is on localhost and uses the
> socket instead of the network port.
> an easy way to test just connectivity is to 'telnet <hostname/ip>
> 3306'.  if you get a connection with some garbled text, your network
> config is ok.

Tried this.  Everything works great.  Not a network connectivity issue.
Thanks for the tip since this allowed me to eliminate that possibility.

> i'd also try a 'select * from mysql.user where user = "mythtv"' and
> look for any differences.

This turned out to be the key.  The password fields were different.  I
assumed that the password was tied to the username alone.  Even using
mysql-admin, this seemed to be the case.  But looking at the table itself
the password fields (or at least their hashes) were different.  So, I
changed the username for all "mythtv" users with:

use mysql;
update user set password=PASSWORD("MYPASSWORD") where user='mythtv';

and now it works perfectly.  Thanks for the help.

I'm still puzzled about a couple of things:

   - Why have I never had this problem before?
   - Why did this suddenly stop working? (I had everything configured
   previously, just fine).  About the only thing I can think of is that an
   update came through and messed it up.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mythtv.org/pipermail/mythtv-users/attachments/20100518/8abb9ab3/attachment.htm>

More information about the mythtv-users mailing list