[mythtv-users] Frontend lockups with Foxconn NT330i

William Suetholz wsuetholz at centonline.com
Wed May 12 12:29:06 UTC 2010

On Wed, 2010-05-05 at 09:59 -0500, William Suetholz wrote:
> Hello,
>   I am attempting to replace my existing Zotac NVidia ION based frontend
> with another NVidia ION based machine, that is a smaller form factor.  I
> picked the Foxconn NT330i-NetDVD, because Newegg had a sale on the
> device.  I basically got the DVD portion for free.
>   Anyways, I first started with a net boot like I'm presently doing, got
> all the configuration to be identical to the existing front end, then
> tried to watch live tv.  It froze quickly.  This is a hard lock, and the
> system does not respond to pings/ssh/num-lock/caps-lock.  There are no
> flashing lights on the keyboard to indicate a kernel fault.  Since then
> I've been playing and testing.  I've found that the live tv locks up
> quicker if it's dealing with a HD stream.  I've also found out that
> playback of recordings and videos will lock up if I jump around in the
> video.
>   I've tried all the settings for VDPAU, and CPU in the playback
> choices,  I thought it might be the muting that happens during tuning in
> the channel and jumping around video playback, so I configured the audio
> output device to be NULL, and set the volume controls to be external.
>   I've tried 9.10 and 10.04 mythbuntu local install on a 16GB SSD.  And,
> before you tell me that 10.04 should have installed 0.23, it didn't.
> Now I've tried the LinHES 06.02.00 install, and it's also stopping at
> the same place.
>   I ran the memory check function for more than 24 hours, and did not
> experience any errors,  I haven't replaced the memory yet though.  
>   I ran mplayer (which was using vdpau) on several videos, including the
> killerbirds.mkv file, the videos were transfered via the network, so I
> tested the network at the same time...
>   I ran the frontend with the -v playback option, the trace output cut
> out while it was writing the timestamp
>   I did come across a blog entry
> <http://nick.kreucher.net/blog/2010/saga-of-the-tiny-mythtv-frontend-part-i/> during my googling that indicates somebody else having the same exact problems.
>   Part of my purchase decision was because of reports of this device
> working well under linux with xbmc...
>   What can I do to track this down?
> Thanks for any help
> Bill

It's all very well to have nobody reply to this email..  It's also ok,
that in the IRC chat I've been told that this is a hardware issue.  And
Foxconn is saying that this is a software issue, since it can't be
reproduced in their rinky-dink OS that is loosely based upon Redhat, but
can't use any software from third party repositories.  Their OS doesn't
use VDPAU at all, and they don't have a compile environment available,
and no MythTV or MPlayer.  Kind of a fake test if you ask me..

Utilizing the hints and suggestions on the NVidia BBS, I found kernel
boot parameters that allow MPlayer to work without locking up the
system.  However, MythTV still locks up in the same manner.
XBMC does not lock up, And I'm able to watch LiveTV using the VLC method
without lockups, it just seems to be MythTV that is still locking up the

My tuners are mostly HDHomeruns, I removed one from the available tuners
for MythTV so that I could play with other ways of watching LiveTV.  I
loose the pausing and ff/rw, but at least it doesn't lock up!

My real question in this rant...  Will 0.23 help with this problem?
But, I'll take any suggestions at all..  WAF is going down fast!!

Thanks for any help.....or even any response...


More information about the mythtv-users mailing list