[mythtv-users] Suddenly no audio

Mark Adams madams9 at gmail.com
Sat May 1 18:08:01 UTC 2010

On 04/30/2010 11:28 PM, Mark Adams wrote:
> Okay, I've gone from acceptable but low volume to silence.
> Mandriva ran a bunch of updates through today and now I get audio 
> everywhere but MythTV.  I repeat: everything (VLC, mplayer, Amarok, 
> Audacious2, everything) plays audio just fine except for MythTV. They 
> even play mpeg files recorded by MythTV with audio just fine.  I have 
> been though the settings methodically changed them over the past two 
> hours in an effort to fix it via trial and error and I have gained 
> nothing.
> Pulse audio is no longer running. And I've done everything I can think 
> of or find by Googling the issue.  I'm very frustrated.  I have no 
> idea where to go from here.  Here are the current (default) settings 
> that worked until this evening:
> Audio Output Device: ALSA:default
> Passthrough Output Device: Default
> Mixer Device: ALSA:default
> Mixer Controls: Master
> Volume controls in MythTV are at 95%.
> Here is the hardware info from lshw:
> *-multimedia
>              description: Audio device
>              product: 82801G (ICH7 Family) High Definition Audio 
> Controller
>              vendor: Intel Corporation
>              physical id: 1b
>              bus info: pci at 0000:00:1b.0
>              version: 01
>              width: 64 bits
>              clock: 33MHz
>              capabilities: pm msi pciexpress bus_master cap_list
>              configuration: driver=HDA Intel latency=0
>              resources: irq:16 memory:f96fc000-f96fffff
> I would really appreciate some help here.
> Thanks.
> Mark
> _______________________________________________

Some additional info.  Aplay -L yields the following:

$ aplay -L
     HDA Intel, ALC662 rev1 Analog
     Default Audio Device
     HDA Intel, ALC662 rev1 Analog
     Front speakers
     HDA Intel, ALC662 rev1 Analog
     4.0 Surround output to Front and Rear speakers
     HDA Intel, ALC662 rev1 Analog
     4.1 Surround output to Front, Rear and Subwoofer speakers
     HDA Intel, ALC662 rev1 Analog
     5.0 Surround output to Front, Center and Rear speakers
     HDA Intel, ALC662 rev1 Analog
     5.1 Surround output to Front, Center, Rear and Subwoofer speakers
     HDA Intel, ALC662 rev1 Analog
     7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
     HDA Intel, ALC662 rev1 Digital
     IEC958 (S/PDIF) Digital Audio Output
     Discard all samples (playback) or generate zero samples (capture)
     PulseAudio Sound Server

How can I configure MythTV to use this sound device?  Again, everything 
else produces audio from these files just fine by default.  Why does 
MythTV have to be so difficult about it?

I would really appreciate some assistance on this.


More information about the mythtv-users mailing list