[mythtv-users] Illegal Instruction Error on G3 iBook+Linux

Michael Papet mpapet at yahoo.com
Sun Mar 28 06:35:03 UTC 2010


I built 0.22-release on a G3 iBook.  Attempting to run mythfrontend crashes out with an 'illegal instruction.'

Poking through the Dev list, it looks like it might be a qmake problem.  The stable version of Debian's qmake package has ppc+Mac(AKA Darwin), but no ppc+Linux.  So, I copied the definition out of a later qmake.  

Now, qmake has the option of 'linux-ppc-g++'.  I don't know two things.

1. What would be the -march incantation?  "linux-ppc-g++"??
2. How to pass the -march=??? through the configure script.

Any ideas would be great.



More information about the mythtv-users mailing list