[mythtv-users] can't shutdown from frontend after recent 0.23-fixesupdate?

Jack Perveiler perveilerj at gmail.com
Wed Jun 30 01:09:48 UTC 2010

On Tue, Jun 29, 2010 at 12:49 PM, Jan Johansson <j2 at mupp.net> wrote:

>  >"No" indeed cancels, and "Yes" indeed closes mythfrontend.  "Yes and
> Shutdown does" nothing (neither exits mythfrontend nor shuts down the >
> system).
>  Are you sure it does nothing? What I have seen in later revisions of
> trunk is that when I exit Mythfrontend the GUI remains on the screen, but it
> is “dead” and the process is actually killed.
> On my system, mythwelcome successfully shuts the system down from this
> scenario. Yes, it is a bit annoying tho J
Yes, I'm sure.  Selecting "Yes and Shutdown" does nothing... I can still
navigate menus and watch recordings as if I never selected it.

That being said, after r25183 (I'm using JYA's 0.23-fixes repositories) I
see from mythfrontend --version that using_qtdbus is now displayed.  Still,
no difference in behavior.  But I noticed that I had the frontend "server
shutdown" configuration item set to a no-longer-existing script
(myth-halt.sh) and, after reading a post from Michael Dean in the thread
"Why won't MythBuntu shut down?" I cleared that entry (it is now empty).
After doing that things are shutting down like they should.

I don't know why things shut down properly with that defunct script in the
settings before, or what changed so that the frontend now cares about it,
but with it clear and with 0.23-fixes post r25183 things are behaving again.

Thanks to all involved,

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mythtv.org/pipermail/mythtv-users/attachments/20100629/7be1400c/attachment.htm>

More information about the mythtv-users mailing list