[mythtv-users] S-video/nvidia problems

Jessica Perry Hekman jphekman at arborius.net
Thu Jul 29 16:08:50 UTC 2010

On Wed, Jul 28, 2010 at 02:23:10PM -0600, Tyler T wrote:

> > When I run nvidia-settings (after rebooting with the LCD plugged in so I
> > ...
> > When X comes back up and I run
> > nvidia-settings again, TV-0 has been turned to "disabled" again.
> I had a similar problem to this (custom overscan reset to default
> after X restart/reboot), and here is my solution. When I saved the
> settings in the nvidia-settings utility, it did NOT save an xorg.conf
> file -- it saved a .nvidia-settings-rc file in my home directory. This
> file must be loaded manually with the command
> nvidia-settings -l
> each time X is launched. I placed the above command in my .xinitrc
> file just prior to my window manager being launched, and now my
> settings are restored as desired.

I tried this (and was very hopeful that it would work). I didn't have an 
.xinitrc yet, but created one containing:

  nvidia-settings --load-config-only &. /etc/X11/xinit/xinitrc

However, when I restarted X, TV-0 still came up "disabled." I'm not sure 
if my .xinitrc is being successfully run or not at this point, or if it 
is being successfully run but something else is wrong.

Looking at my .nvidia-settings-rc file, though, I am not sure that 
nvidia-settings is actually generating that file when I run it. The file 
says it was generated on Jul 22, even though I have re-run 
nvidia-settings multiple times since then. Also, I can explicitly ask 
nvidia-settings to save to xorg.conf, and I do see that that file gets 

I really wanted this solution to work, but either your system is 
different from mine, or -- maybe I am missing something?


More information about the mythtv-users mailing list