[mythtv-users] Ongoing sound problems/plugins aren't working after update (25171)

Bob Sully rcs at malibyte.net
Sat Jul 3 05:21:43 UTC 2010

Bob Sully wrote:
> Hi all -
> Using JYA's 0.23-fixes repositories.
> The only problem I've been having with Myth up to this point: sound - most
> of the time I have it, sometimes I don't - and when I don't, getting out
> of the frontend, running alsamixer and muting/unmuting the "master volume"
> would bring it back; I had to do this every so often, and always after
> rebooting.  A pain in the @$$ but not a dealbreaker, since I usually
> control the Myth machine here at the abode; if my daughter wants to watch
> something she usually asks me to play it for her - because of this
> problem.
> I upgraded to JYA's 0.23-fixes, rev. 25171 today - hoping that the recent
> audio code changes would give me reliable sound.
> After doing the update: (1) none of the plugins work.  The database schema
> update to 1259 appears to have gone OK, mythfilldatabase ran, but I kept
> getting errors about the protocol version (config file says 56, but
> actually using 57).  I changed the value to 57 in the config file (can't
> recall the filename ATM).  Still - mythvideo, mythmusic and the internet
> video plugins don't work at all.  Mythweb comes up, but doesn't display
> the previously recorded shows or the upcoming recordings.  Listings come
> up, I can search on them, but if I try to schedule a recording (via
> Mythweb) I get an error:
>    datetime:  2010-06-30 20:49:49 (PDT)
>     errornum:  256
>   error type:  User Error
> error string:  SQL Error: Unknown column 'tsdefault' in 'field list'
> [#1054]
>     filename:  /usr/share/mythtv/mythweb/classes/Database/Query/mysql.php
>   error line:  83
> I assume that I still have a database problem, even though the schema
> update appeared to work.  The MythTV recordings are all there, though - at
> least the frontend seems to find them OK.
> Now - sound:
> I am using S/PDIF, through the coaxial output into a Sony receiver (7.1
> capable, but only using 5.1, because that's my speaker setup; when I have
> sound in Myth, it's indeed 5.1, and all other sources (Blu-Ray player,
> etc. - work fine).
> The onboard sound card has this setting for the S/PDIF output:
> iec958:CARD=Intel,DEV=0
>     HDA Intel, AD198x Digital
>     IEC958 (S/PDIF) Digital Audio Output
> I am using this value in the "audio device" field at the top of the setup
> page.  No sound at all.  Same if I type in "ALSA:spdif".  Doesn't matter
> what I do, even if I ssh in from another machine, run alsamixer,
> mute/unmute.  No sound.
> If I check "Separate digital audio output device" and use
> "ALSA:iec958:0x02" or "0x06" (have to do that last manually):
> No sound, but on the receiver, it comes up saying it's a Dolby digital
> recording, and the display flashes.  If I ssh in from another machine and
> run alsamixer, hit the "M" key twice to mute/unmute -> I get 5.1 sound and
> the flashing stops.
> Now, if I exit that recording and start another - no sound, display
> flashes again until I hit "M" twice from the ssh session on the other box.
> I tried removing PulseAudio as per:
> http://ubuntu-ky.ubuntuforums.org/showthread.php?t=1313253
> No difference.  Rebooted the box at least three times over the past few
> hours.
> If anyone can help me get these issues straightened out I'd appreciate it.
> I had this problem with the plugins before and it resolved after the next
> update.  No new updates available via the update-manager yet.
> The sound problem has got me tearing my hair out.  Jean-Yves tried to help
> before but to no avail.
> If anyone can help with this, please hit me back.  If you feel that this
> has been beat to death on-list, please e-mail me directly at:
> rcs at malibyte.net

Replying to my own post - an update:

I have three sets of partitions on my BE/FE's system disk for various
iterations of Myth.

After the upgrade above (JYA's 0.23-fixes/0.24-trunk-25171, with plugins
at 25221, on Ubuntu 9.10) - Myth was basically unusable.  Sound was fully
b0rked and I couldn't access my videos (other than Myth recordings) or use
any plugins.  I copied this setup to a second set of partitions and
restored my pre-update system from backup (so I now have a working system

The interesting part:  I booted again into the dysfunctional system and
did a dist-upgrade to 10.04.

After this upgrade:  SOUND IS WORKING - in 5.1, seems reliably - WITHOUT
the need to fart around with alsamixer (as I've had to do for a long
time!), at least with the Myth recordings.  ALSA:iec958 is the audio
device, and the "separate audio device" is hw0,1.

I still can't run ANY of the plugins (Protocol version mismatch: the
backend appears to be running 56 and the plugins, 57, or vice versa).  It
appears that I won't be able to run my new install until the next update,
when the protocols match.

However, as JYA has been madly updating the sound code, I just wanted to
let him know that this problem may FINALLY be fixed on this machine, with
the changes he's made.  Much appreciated!


Bob Sully - Simi Valley, California, USA

More information about the mythtv-users mailing list