[mythtv-users] Ongoing sound problems/plugins aren't working after update (25171)

Bob Sully rcs at malibyte.net
Thu Jul 1 04:06:35 UTC 2010

Hi all -

Using JYA's 0.23-fixes repositories.

The only problem I've been having with Myth up to this point: sound - most
of the time I have it, sometimes I don't - and when I don't, getting out
of the frontend, running alsamixer and muting/unmuting the "master volume"
would bring it back; I had to do this every so often, and always after
rebooting.  A pain in the @$$ but not a dealbreaker, since I usually
control the Myth machine here at the abode; if my daughter wants to watch
something she usually asks me to play it for her - because of this

I upgraded to JYA's 0.23-fixes, rev. 25171 today - hoping that the recent
audio code changes would give me reliable sound.

After doing the update: (1) none of the plugins work.  The database schema
update to 1259 appears to have gone OK, mythfilldatabase ran, but I kept
getting errors about the protocol version (config file says 56, but
actually using 57).  I changed the value to 57 in the config file (can't
recall the filename ATM).  Still - mythvideo, mythmusic and the internet
video plugins don't work at all.  Mythweb comes up, but doesn't display
the previously recorded shows or the upcoming recordings.  Listings come
up, I can search on them, but if I try to schedule a recording (via
Mythweb) I get an error:

   datetime:  2010-06-30 20:49:49 (PDT)
    errornum:  256
  error type:  User Error
error string:  SQL Error: Unknown column 'tsdefault' in 'field list' [#1054]
    filename:  /usr/share/mythtv/mythweb/classes/Database/Query/mysql.php
  error line:  83

I assume that I still have a database problem, even though the schema
update appeared to work.  The MythTV recordings are all there, though - at
least the frontend seems to find them OK.

Now - sound:

I am using S/PDIF, through the coaxial output into a Sony receiver (7.1
capable, but only using 5.1, because that's my speaker setup; when I have
sound in Myth, it's indeed 5.1, and all other sources (Blu-Ray player,
etc. - work fine).

The onboard sound card has this setting for the S/PDIF output:

    HDA Intel, AD198x Digital
    IEC958 (S/PDIF) Digital Audio Output

I am using this value in the "audio device" field at the top of the setup
page.  No sound at all.  Same if I type in "ALSA:spdif".  Doesn't matter
what I do, even if I ssh in from another machine, run alsamixer,
mute/unmute.  No sound.

If I check "Separate digital audio output device" and use
"ALSA:iec958:0x02" or "0x06" (have to do that last manually):

No sound, but on the receiver, it comes up saying it's a Dolby digital
recording, and the display flashes.  If I ssh in from another machine and
run alsamixer, hit the "M" key twice to mute/unmute -> I get 5.1 sound and
the flashing stops.

Now, if I exit that recording and start another - no sound, display
flashes again until I hit "M" twice from the ssh session on the other box.

I tried removing PulseAudio as per:

No difference.  Rebooted the box at least three times over the past few

If anyone can help me get these issues straightened out I'd appreciate it.
I had this problem with the plugins before and it resolved after the next
update.  No new updates available via the update-manager yet.

The sound problem has got me tearing my hair out.  Jean-Yves tried to help
before but to no avail.

If anyone can help with this, please hit me back.  If you feel that this
has been beat to death on-list, please e-mail me directly at:

rcs at malibyte.net

Thanks very much.
Bob Sully - Simi Valley, California, USA

More information about the mythtv-users mailing list