[mythtv-users] Error While Running TCREQUANT

Jens Holzhaeuser Jens.Holzhaeuser at gmx.net
Tue Feb 2 18:33:31 UTC 2010

On Sat, Jan 30, 2010 at 09:16:55PM +0000, Stephen Kitchener wrote:
> On Saturday 30 Jan 2010, Nick Rout wrote:
> > On Fri, Jan 29, 2010 at 12:21 PM, Stephen Kitchener
> >
> > <stephen at g6dzj.demon.co.uk> wrote:
> > > Hi,
> > >
> > > Apologies it this is an FAQ, but am I correct in thinking that tcrequant
> > > is now missing from mythtranscode ??
> > >
> > > I have only just installed 0.22, a couple of weeks, and I was seeing if
> > > mytharchive still worked for me, and I got the error in the subject line.
> > >
> > > I realise that 0.23 is due out soon and that this may be addressed in
> > > this coming release, but I thought that I should ask.
> > >
> > > I am assuming that tcrequant is a separate executable and should be found
> > > from a "locate" issued from the root user, but nothing was found.
> > >
> > > I am using Fedora 12 and atrpms repos and mythtv 0.22
> > >
> > > Is there something that I can do to fix this please - or should I wait
> > > till 0.23 is released ??
> > >
> > > Thanks
> >
> > tcrequant should be in the transcode package. If it isn't installed
> > then presumably your packager has forgotten to include it as a
> > dependency.

tcrequant has been deprecated by the upstream transcode developers.
It seems it has some bugs and is not actively developed anymore by anyone, 
so it will only be compiled with the --enable-deprecated (or something
similar, from memory) option to the configure script of the transcode 

On my debian system I usually apt-get the source from debian-multimedia, 
change the debian package files, compile a .deb and install that. 

I can post more details tonight if anybody is interested, but it's 
fairly easy to figure out.
> Thanks for the suggestion, I have read somewhere, can't remember which list, 
> but it may have been atrpms, that 64 bit machines running tcrequant 
> executables, would produce unplayable files, so as I am running a 64 bit 
> machine, this might not be a go. So in reality I am looking for a replacement 
> somewhere. 

tcrequant is only used if the resulting files are too large to fit
the DVD. It doesn't work in all cases, it's a hit and miss, but I
would think it's not really a 32/64 bit issue.

> Unless someone else has done this and fixed it ??

An alternative would be nice, but I haven't really found anything with
googeling. Suggestions welcome.

I had hoped an alternative would be provided with 0.22 (I am still running
0.21), but I guess not. If somebody points to an alternative binary for
this task, I probably could provide adapted mythtrancode scripts.


More information about the mythtv-users mailing list