[mythtv-users] Storage Groups and Subtitles

Mark Kendall mark.kendall at gmail.com
Tue Dec 21 03:41:10 UTC 2010

On 17 December 2010 23:25, Andy <mizeraka at yahoo.com> wrote:
> HI,
> I am having some issues with mythtv 0.24.
> 1. mythvideo will not display subtitles for mp4 videos.  I can get the same mp4 video to display subtitles in VLC.  These mp4 files are created with handbrake to back up DVDs that I own.  I was under the impression that mythvideo in 0.24 would correct this problem.  Did I miss something or was I misinformed?

Can you post a short clip (30 seconds)  from one of the problem files
to filebin.ca ? I can then either see why it's broken or look into
adding support.

> 2. I cannot change the subtitle font in mythvideo.  While the white is better than the yellow, the font is still not ideal.  Changing the font under Playback OSD only seems to change the closed captioning font in TV (live or recorded) but not the subtitle font in mythvideo.  Is there a way to change the subtitle font in 0.24?

As Raymond has already noted, those captions are bitmap images as
ripped originally from your dvd. The change in color from 0.23 to 0.24
is because I tweaked the default colour palette in ffmpeg - which for
some reason contains yellow rather than white. Unfortunately, when
dvd's are ripped into other formats (e.g. matroska), the original
colour palette for those images is not retained and we have to guess a
reasonable default set. Sometimes this results in an 'inverted'
palette with, for example,  white borders around black text rather
than black around white.



More information about the mythtv-users mailing list