[mythtv-users] Can I decompose load on CPUs during VDPAU SPDIF playback?

Dave Richardson mythtv at derdev.com
Mon Dec 20 11:53:03 UTC 2010

 On Sun, 19 Dec 2010 18:50:15 +1100, Jean-Yves Avenard 
 <jyavenard at gmail.com> wrote:
> On 19 December 2010 03:36, Dave Richardson <mythtv at derdev.com> wrote:
>> 2010-12-18 10:20:09.211 AO: OutputAudioLoop: audio paused
>> 2010-12-18 10:20:09.302 Player(0): Waited 100ms for video buffers
>> 2010-12-18 10:20:09.311 Player(0): Waited 100ms for video buffers
>> 2010-12-18 10:20:09.320 Player(0): Waited 100ms for video buffers
> Did you try increase the VDPAU buffer size?
> you do this by editing the TV playback profiles and change the
> deinterlacing filter.
> not the most obvious way , but you configure it there
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users

 I tried the buffer size, no love.  Then I took at look at why some 
 codecs might be a problem, not enuf information to make sense.  Then I 
 tried to understand why the deinterlacer errors came up, tough to google 
 on that but it seemed like something was wrong with the driver or vdpau 

 After noting that the machine had been upgraded and had a potentially 
 incompatible mix of repos (ppa, JYA, auto-builds) I got pissed off and 
 reinstalled a clean mythbuntu 10.10.  Used just the open source driver 
 and upgraded all software and enabled JYA repos.  Then added the nvidia 
 256 driver.

 STILL didn't work.  That pissed me off again.  Then I said to myself 
 "fine, just dial down the VDPAU performance to get it to work a little 
 bit".  So I switched from the default VDPAU High Quality profile to the 
 medium profile (next profile 'down').  That worked pretty good with no 
 logged errors.

 After watching on the medium profile I switched back up to the High 
 Quality profile using ADV 1x and Temporal 1x and the deinterlacer errors 
 went away!  I cannot explain this other than it appears to me that there 
 are config settings for the FE that are stored on the BE???  If that's 
 the case and after all the upgrades and gymnastics, I may have had a bad 
 or conflicting setting in my profile that wouldn't clear from the BE by 
 just fiddling with the HQ profile on its own?

 It seems that when I toggled the profile away from High Perf and back, 
 that made a difference.  At least the errors cleared up!

 I almost marked this as [SOLVED] but I can't say that I know any more 
 than when I started, feels like dumb luck or bad inductive reasoning.

More information about the mythtv-users mailing list