[mythtv-users] git 0.24 fixes broken UK DVB-T Radio playback (Waited 100ms for video buffers)

John Pilkington J.Pilk at tesco.net
Sun Dec 19 10:52:16 UTC 2010

On 19/12/10 09:45, Duncan Brown wrote:
> Hey
> There seems to be an issue with fixes currently which is preventing
> playback of DVB-T radio channels in the uk
> Switching to one (recorded or live) results in the logs being filled with:
> Player(b): Waited 100ms for video buffers AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
> and then the frontend crashes with
> Error: Waited too long for decoder to fill video buffers. Exiting..
> 2010-12-19 09:34:55.113 TV: Attempting to change from WatchingLiveTV to
> None
> 2010-12-19 09:35:00.218 Player(b), Error: Failed to stop decoder loop.
> 2010-12-19 09:35:00.248 VDPAU Painter: Clearing VDPAU painter cache.
> pure virtual method called
> terminate called without an active exception
> I'm using the latest fixes from atrpms, but the git versioning issue
> makes it difficult to say exactly what version I have
> Looking through the commits I assumed it didnt include this one:
> https://github.com/MythTV/mythtv/commit/588cc6e2b3818d1c9c9af97b233b28914c226ea6
> but Axel has confirmed the build I'm using already has that fix
> Is anyone else seeing this?
> cheers
> Dunc

Confirmed.  I tried R3 live and got similar 'waiting too long' 
messages. I'm not using VDPAU.  Then tried a normal R3 recording, which 
started and stopped within a few seconds. Tried R4 recording, got a 
'program not found in PAT' message and 'rescan your PAT', but now the 
disc sounds as if it's recording and  playback works for a few seconds; 
then 'video frame buffering failed too many times'.  That box isn't 
online at present, so I can't post real output.  I'll check later to see 
if my normal practice of stripping out and saving only the mp2 stream 
works.  It's the same ATrpms spin, 0.24-256, on el5.

John P

More information about the mythtv-users mailing list