[mythtv-users] Problem playing last program before a channel stops broadcasting for the day (UK DVB-T)

John Veness John.Veness.mythtv at pelago.org.uk
Sun Dec 12 20:25:32 UTC 2010


I have the following problem on a UK DVB-T (Freeview) setup, which 
started when I upgraded to 0.24. I didn't have this problem in many 
months of 0.22. I only ran 0.23 for a couple of days so don't know if it 
occurred there.

A few channels on Freeview are not broadcast 24-hours. For example, Five 
USA stops at 1am, and CBBC stops at 7pm. If I try to playback a 
recording of the final program on a channel, i.e. one that ends at 1am 
on Five USA or which ends at 7pm on CBBC, then the playback doesn't work.

Specifically, what I see is a blank (black) screen and no audio. I can 
skip around the playback and press I and see an accurate progress bar, 
but see/hear no content.

As far as I can tell, the programs are actually being recorded OK. I can 
play back the raw files with mplayer, for example. And if I watch one of 
the recordings while they are being recorded, they show fine. Something 
seems to be happening that is causing Myth to not play back these 
recordings when they are finished.

Most of the affected recordings have been made since 0.24, but I have 
one recording that was made during the 0.22 days that is also exhibiting 
this problem. This same recording played fine in 0.22, but no longer 
plays in 0.24.

On affected recordings, the preview picture is also blank (although grey 
rather than black). They also error if I try to do a lossless transcode 
on them.

I record 3 minutes past the end of the scheduled time. I haven't yet 
tried to see what would happen if I stop exactly when the channel ends.

Has anyone else seen this problem? Any suggestions for troubleshooting? 
Shall I report this as a bug?



John Veness, MythTV user, UK, DVB-T

More information about the mythtv-users mailing list