[mythtv-users] Another lirc issue

Jarod Wilson jarod at wilsonet.com
Thu Dec 9 20:43:19 UTC 2010

On Dec 9, 2010, at 12:46 PM, Jarod Wilson wrote:

> On Thu, Dec 9, 2010 at 1:07 AM, Matt Goebel <matt at goebelnet.com> wrote:
>> I've noticed a lot of lirc issues on this list lately but really haven't paid close attention to them as I'd not experienced any issues until now.
>> Can someone bring me up to speed with what's going on?
> I can try...
>> I have a mceusb receiver, this one:
>> Bus 009 Device 002: ID 1784:0008 TopSeed Technology Corp. eHome Infrared Transceiver
> Okay, good, I've got this very same hardware.
>> Using a Harmony remote, don't think that matters.   Fedora 14.  Only the latest kernel,, seems to break anything.  If I run irw I see about 60% of the keys on the remote don't register anything regardless of how many times I press them.  A portion of the ones that do, seem to take several presses.  All earlier kernels I've been 100% fine.  I've reverted back to for now.
> What does your lircd.conf look like? I actually expected that kernel
> to generally *improve* the performance of receive on mceusb devices...
> I ought to be able to reproduce the problem here though.

Crap. The mceusb driver in that kernel isn't quite as up to date
as I thought, apparently. I've reproduced an issue that I know
I've already fixed upstream, so there must be a missing patch or
two that I'll have to add to a newer build.

Jarod Wilson
jarod at wilsonet.com

More information about the mythtv-users mailing list