[mythtv-users] MythTV 0.24 HDMI audio problem

John P Poet jppoet at gmail.com
Thu Dec 9 05:56:40 UTC 2010

On Mon, Dec 6, 2010 at 10:47 PM, Jean-Yves Avenard <jyavenard at gmail.com> wrote:
> Hi
> On 7 December 2010 16:33, John P Poet <jppoet at gmail.com> wrote:
>> I now have a HDMI equipped pre-amp, so now I am trying to get sound to
>> work.  Unfortunately, the EDID stuff does not seem to be my problem.
> How can you be sure ? :P
> edid good or not, you can't tell from looking at the list of the alsa
> devices, not could I see anything in the kernel log ..

I made an assumption based on the fact that my xorg.conf options did
not match the ones that you indicated caused a problem.


>> Then I tried changing Myth to use "ALSA:plughw:0,7", and I got sound,
>> but LCPM does not work (only bitstream).  So, I then tried the other
> What make you say that LPCM didn't work ?

When I kick on timestretch, the pre-amp switched from showing Dolby
Digital 5.1, to PCM 2.0 and only the two primary speakers are used --
the others are quiet.  This make me think myth is trying to use LPCM,
but it is not making it to my pre-amp.

When I run alsamixer it lists ALL the outputs from the nvidia GT220
card as being S/PDIF.  Is that correct?  I would half expect HDMI to
be different from S/PDIF.

I have not tried your latest updates yet.  Is multi-channel ( > 2 )
LPCM working for you?


A: Because it messes up the order in which people normally read text.
Q: Why is top-posting such a bad thing?

More information about the mythtv-users mailing list