[mythtv-users] MythTV 0.24 HDMI audio problem

Jean-Yves Avenard jyavenard at gmail.com
Tue Dec 7 05:47:05 UTC 2010


On 7 December 2010 16:33, John P Poet <jppoet at gmail.com> wrote:
> I now have a HDMI equipped pre-amp, so now I am trying to get sound to
> work.  Unfortunately, the EDID stuff does not seem to be my problem.

How can you be sure ? :P

edid good or not, you can't tell from looking at the list of the alsa
devices, not could I see anything in the kernel log ..

> What is interesting, is that "aplay -l" lists three HDMI devices:
> # aplay -l
> **** List of PLAYBACK Hardware Devices ****
> card 0: NVidia [HDA NVidia], device 3: NVIDIA HDMI [NVIDIA HDMI]
>  Subdevices: 0/1
>  Subdevice #0: subdevice #0
> card 0: NVidia [HDA NVidia], device 7: NVIDIA HDMI [NVIDIA HDMI]
>  Subdevices: 1/1
>  Subdevice #0: subdevice #0
> card 0: NVidia [HDA NVidia], device 8: NVIDIA HDMI [NVIDIA HDMI]
>  Subdevices: 1/1
>  Subdevice #0: subdevice #0
> card 0: NVidia [HDA NVidia], device 9: NVIDIA HDMI [NVIDIA HDMI]
>  Subdevices: 1/1
>  Subdevice #0: subdevice #0
> "aplay -L" just lists one:

This is expected, that's what most hdmi devices look like on the GT card.
If you have a recent version of the alsa-library (more recent than
1.0.23), then aliased are created so you can use them without having
to play with the hw entry
A device would be called:

> If I try to do "speaker-test -Dhdmi:CARD=NVidia" it says that it is
> producing audio, but I don't hear anything.

> If I add a bit to my /etc/asound.conf file:
> ~~~~~~~~~~~~~~~~~~~~~~~
> pcm.nvidia_hdmi {
>  type plug
>  slave {
>    pcm "hw:0,7"
>  }
> }
> pcm.!default nvidia_hdmi
> pcm:iec958 nvidia_hdmi
> ~~~~~~~~~~~~~~~~~~~~~~~
> Then *just* type "speaker-test", I *DO* get sound!  At this point, I
> can use aplay to play wav files.
> Note, that if I change the asound.conf file to have:
>  pcm "hw:0,3"
> Then I don't get any sound.  with "hw:0,7", "hw:0,8" and "hw:0,9" I
> *do* get sound.
> With that /etc/asound.conf, I tried telling myth to use "ALSA:default"
> for it's audio device, but I still did not get any sound.
> Then I tried changing Myth to use "ALSA:plughw:0,7", and I got sound,
> but LCPM does not work (only bitstream).  So, I then tried the other

What make you say that LPCM didn't work ?

> possibilities:
> "ALSA:plughw:0,3"  - have sound
> "ALSA:plughw:0,7"  - have sound
> "ALSA:plughw:0,8" - have sound
> "ALSA:plughw:0,9" - do not have sound ????
> In none of the cases that actually produced sound, did LCPM work.  I
> find it odd that in the asound.conf, it was device 0,3 that did not
> work, and in Myth it seems to be device 0,9 that did not work --
> strange.
> Using the "ALSA:plughw" entries means that the asound.conf is not
> necessary, but I am leaving it in the hopes that I can get flash audio
> working.

Some people have reported that for PCM and stero they use one device,
and for passthrough they use another.

So you can try overriding the passthrough device and set two different device.

> I would like to have LCPM working, but what I have will get me by for now.

it probably is working :)

More information about the mythtv-users mailing list