[mythtv-users] HD-5500 audio with .24

Trevan Richins trevan_myth at therichins.net
Sun Dec 5 06:37:11 UTC 2010


I recently updated MythTV from .23 to .24 (as well as Mythbuntu from
10.04 to 10.10) and now I have audio issues.  I first built a custom
kernel with OSS enabled (since Ubuntu 10.10's kernel no longer has it
built in).  This gets me audio correctly but I can't change channels in
Live TV mode (it will either exit back to the main menu with a message
"Error opening jump program file" or it will crash mythfrontend).  I can
record on any channel and watch recordings, though.

So I asked around on the Mythbuntu's forum and was pointed to this
It deals with setting up pulseaudio.

I've turned on pulseaudio.  I've set the audio device for the hd5500 in
the mythbackend setup to ALSA: default.  I've set the frontend to use
ALSA: Pulse (after scanning for audio devices).  I can now change
channels without problems but I don't get any sound.  I can watch any
old recording, but new ones don't have any sound.

If I run "sox -c 1 -t alsa default -t alsa default", I hear the TV
correctly.  Changing channels in MythTV changes the sound as well
(though it is off sync because MythTV buffers the video and sox doesn't
buffer the audio).  Also, if I run "pactl load-module module-loopback"
(from http://www.pulseaudio.org/ticket/665), I hear the sound as well.

Does anyone have an idea on what I'm missing?


More information about the mythtv-users mailing list