[mythtv-users] Analog multi-channel sound, optimal configuration 0.24?

Terjesen Jens Peder Jens.Peder.Terjesen at devoteam.com
Fri Dec 3 10:13:46 UTC 2010


I have browsed and searched on the MythTV Wiki but not really found any information.

I am running MythTV 0.24 on OpenSuse 11.2 and want to use my old analog only surround receiver for sound.

I have it up and running with the MythTV box connected to the receiver with 3 minijack to RCA cables (front, center, surround and LFE).
I first tried the onboard soundcard which worked but didn't give very great sound.
Yesterday I installed an old unused Creative Soundblaster Audigy 2 which I had lying around and it was a significant improvement.

What is the best configuration in MythTV for this setup?

I have selected ALSA:surround51 as sound device.
At the moment I do not have a Subwoofer and have said so in the setup in the receiver which I think then will mix the LFE channel to the front speakers. 
Would it be better to use ALSA:surround50? Would alsa or MythTV do this mixing instead then?

When running speakertest with 6 channels it displayed LFE but the played sound said "center rear". 
Is this normal or an indication that the channels are mixed up?

Also when the cable for LFE was connected to the Subwoofer input on the receiver there was no sound, I had to pluf it into the Center input to hear the sound.
Is it probable that the frequency of the sound from speakertest is too high for the sound to be mixed to the front speakers by the receiver? Or is this an indication that the LFE is not mixed to the front speakers at all by the receiver? Is there an easy way to send a low frequency to the receiver to test this?

I guess that I should select upmix of stereo to surround if I want sound from all speakers all the time?


More information about the mythtv-users mailing list