[mythtv-users] mythtv-database incorrect admin username/password error during .22 upgrade

Johnny jarpublic at gmail.com
Tue Oct 20 15:36:40 UTC 2009

I have seen the following error before in the past, but it caused me a
lot of unnecessary grief when I updated to .22 last night:

Failed to create or modify database (incorrect admin username/password?)
sudo dpkg-reconfigure mythtv-database

It happens when apt is installing or updating mythtv-database. Running
'sudo dpkg-reconfigure mythtv-database' results in exactly the same
error. I have searched the archives and tried what I could find, e.g.
having no mysql root password and also setting up mysql root with an
"old" type password. No matter what I do this error still comes up. I
recall this happening when I would update .21-fixes sometimes but it
never seemed to cause a problem.

 However, when upgrading to .22 it appeared to me that it was failing
to update the database to the new schema. I spent a lot of time trying
do get this to work properly (under the assumption that this was
critical to upgrading the database for .22) and probably did more harm
than good (reinstalling mysql, redoing mythconverg database etc). In
the end I ran the new frontend and that is when it actually upgraded
the database (which helped me remember reading somewhere that that was
the way it would happen). So my question is two fold. What is wrong
with mythtv-database and how do we get it to run without failing?
Second if this package failing doesn't affect the ability to upgrade
successfully, what is it even doing? I am currently running mythbuntu
9.04. And .22 is great by the way. Thanks for all the work.

More information about the mythtv-users mailing list