[mythtv-users] Slightly OT: irexec issues

John H arizonamythtv at gmail.com
Wed Oct 14 18:46:47 UTC 2009

I have no problems with irexec when I boot up. The problem I run into
is that irexec will just die on me. I figure no problem I'll use monit
to monitor irexec. Well after figuring out display issues I've got it
somewhat working

start program = "/bin/bash -c 'killall irexec; rm
/var/run/irexec/irexec.pid; export DISPLAY=:0.0; /usr/bin/irexec -d
/home/john/.mythtv/lircrc; /bin/pidof irexec >
 as uid john

I have a script that starts the frontend and turns on the tv through a
serial port. I couldn't get lirc to work with the mythfrontend started
through the restarted irexec as it said it couldn't find the
./.lircrcr file. Don't know why it was looking here since irexec and
the script is owned by me user and the frontend starts as me. I ended
up using a symbolic link and got this to work.

The problem I have now is I can't get this simple little echo command
to work in the script.

echo "POWR1   " > /dev/ttyS2

If I run from the command line it works.

If I change it to

echo "POWR1   " > /home/john/testme.log

the echo arguments are written to the file. I cannot figure out why it
won't write to the /dev/ttyS2

doing a ls -al /dev/ttyS2 says it's owned by root and in group
dialout. I've added everyone to dialout.

I hooked the serial cable between two computers and fired up minicom
and when I do it command line I see it show up in the terminal when I
press the remote button that calls the script with the echo command
nothing. I did fire up ircat irexec and the script is being called.
Any ideas? Using Mythbuntu.

More information about the mythtv-users mailing list