[mythtv-users] ATI TV Wonder HD 600 USB Remote control

Patrick Doyle wpdster at gmail.com
Wed Nov 25 23:28:27 UTC 2009

OK, I've started to get somewhere, at least a little bit, but I'm
quite sure that I'm going down the least efficient and least elegant
way to do this...

I ran:

$ irrecord -H dev/input -d /dev/input/event5 test.conf

and recorded each of the 24 keys as


producing a lircd.conf that looks like this:

begin remote

  name  5000038300G
  bits           16
  eps            30
  aeps          100

  one             0     0
  zero            0     0
  pre_data_bits   16
  pre_data       0x8001
  gap          100006
  toggle_bit_mask 0x0

      begin codes
          KEY_RECORD               0x00A7
          KEY_PLAYPAUSE            0x00A4
          KEY_STOP                 0x0080
          KEY_POWER                0x0074
          KEY_PREVIOUS             0x019C
          KEY_REWIND               0x00A8
          KEY_FORWARD              0x009F
          KEY_NEXT                 0x0197
          KEY_EPG                  0x016D
          KEY_HOME                 0x0066
          KEY_MENU                 0x008B
          KEY_CHANNELUP            0x0192
          KEY_BACK                 0x009E
          KEY_UP                   0x0067
          KEY_INFO                 0x0166
          KEY_CHANNELDOWN          0x0193
          KEY_LEFT                 0x0069
          KEY_SELECT               0x0161
          KEY_RIGHT                0x006A
          KEY_VOLUMEUP             0x0073
          KEY_LAST                 0x0195
          KEY_DOWN                 0x006C
          KEY_MUTE                 0x0071
          KEY_VOLUMEDOWN           0x0072
      end codes

end remote

I note that the key codes match the corresponding codes given in

Then I made my hardware.conf look like this:
#Chosen Remote Control
REMOTE="ATI TV Woner HD 600"

#Enable lircd

Now I've started creating a ~/.lirc/mythtv that looks like this:
    remote = 5000038300G
    prog = mythtv
    button = KEY_DOWN
    config = Down
    repeat = 0
    delay = 0
    remote = 5000038300G
    prog = mythtv
    button = KEY_UP
    config = Up
    repeat = 0
    delay = 0


I can keep going for all 24 buttons on the remote and I expect I'll
get them all to work, but as I said, this just feels wrong.  It seems
silly to define a lircd.conf that produces the same set of codes as
are hard coded into the kernel in drivers/media/common/ir-keymaps.c
for this remote.  Then it seems silly to have to map those set of 24
symbols again in ~/.lirc/mythtv.

And, before I started this process (of creating the appropriate
hardware.conf and lircd.conf files and starting the lircd), when I
pressed the volume up, down and mute buttons, they controlled output
volume of my PC.  Now they do not, presumably because lircd is
grabbing them from /dev/input/event5 instead of letting them flow
through to wherever they were going previously.

I suppose I could recompile ir-keymaps.c to make the buttons match the
proper keycodes as defined in keys.txt, but that would be even more
kludgy than the path I'm on now.

There is something very fundamental in the operation of IR remotes and
their connections to mythtv and other applications that I am missing.

What is it?


On Tue, Nov 24, 2009 at 10:23 PM, Patrick Doyle <wpdster at gmail.com> wrote:
> Did any of you folks who bought the WOOT special a few weeks ago get
> the remote to work?
> If so, what did you do?
> I'm using Mythbuntu 9.10.  I open up the Mythbuntu Control Centre and
> tried to configure the remote.  The only ATI remotes I see are
> "ATI/NVidia/X10 I & II RF Remote" and "ATI/NVidia/X10 RF Remote
> (userspace)".
> I tried the first one, even though this remote has an LED on the front
> and the USB stick has a suspiciously looking IR receiver on the side.
> When I tested it with irw, the only buttons that seemed to do anything
> were the up, down, left, right, and Home buttons.  Strangely though,
> the volume up, down, and mute buttons seemed to control the volume.
> There seems to be a slight bug in the Control Centre -- when I select
> this remote and apply the changes, the panel displays as if no remote
> were selected.  If I look in /etc/lirc/hardware.conf, I see:
> REMOTE="ATI/NVidia/X10 I REMOTE="ATI/NVidia/X10 I & II RF Remote" II RF Remote"
> If I fix that to read
> REMOTE="ATI/NVidia/X10 I & II RF Remote"
> Then the Control Centre displays the correct remote.
> (It would seem that there is a bug in the code that updates the
> REMOTE= line when the string being inserted contains the word
> "remote".)
> Anyway, I get the same behavior when I select the userspace driver.
> (only 5 buttons reports by irw, but the volume can be controlled).
> I've tried (or, more accurately, tried to try) a lirc.conf file I
> found at http://lircconfig.commandir.com with the same results (which
> makes me think that I didn't actually get the right lirc.conf file in
> the right place.
> --wpd

More information about the mythtv-users mailing list