[mythtv-users] Commercial Flagging in the UK

Mark Garland mythtvusers at markgarland.co.uk
Sat Nov 21 17:24:29 UTC 2009

> > Basically, commercial flagging just doesn't work for me (Myth 0.22).


I'm based in the UK and would say that the commercial flagging has worked
pretty well in both 0.21 and 0.22.

In particular, I quite like watching the old Star Trek Voyager series on
Virgin's channel (channel 20?) and that really does work well.  Every single
advert is caught and skipped beautifully to the second.

Occasionally it can get confused - I remember watching a cartoon called "Bob
and Margaret" and the screen faded to black between scenes - that confused

I've just asked the missus and she informs me that the More4 channel doesn't
work well for her - "How Clean Is Your House" and "Location, Location,
Location" being the worst offenders.  She tells me that it occasionally
misses adverts completely, although she just skips manually.

Even though the BBC programmes do not have commercials, I still run
mythcommsflag over them.  As I record a few minutes before (and after) to
account for schedule slippage, running mythcommsflag over the programme
means that the beginning few minutes of wasted recording is skipped over and
as soon as play is pressed the programme starts perfectly.

As to settings, mine has just come out of the (K)Ubuntu repositories, so
whatever they're set to as default is what I'm using.  Would be happy to
look up the settings explicitly if requested.

Hope that helps,


More information about the mythtv-users mailing list