[mythtv-users] PVR-350 won't record without reboot

Will Kennerly theoreticalchemistry at yahoo.com
Sat Nov 21 13:47:31 UTC 2009

My backend has one PVR-350 tuner; the system is running MythTV 0.21 on Fedora 11.  I have had this system working well for several years.

Some time ago, I think it was when the ivtv drivers became included in the official kernel, things went bad.  After a few recordings, the system would stop recording (leaving empty files for the video files).  Only a reboot fixes it, but of course, only a few recordings complete successfully.

The error message one sees in mythbackend.log is:
MPEGRec(/dev/video) Error: select timeout - ivtv driver has stopped responding

I've googled around for this.  Apparently many other people have had this problem (with other now antiquated PVR-x50 type cards) but I couldn't find any obvious common solution.  One person claimed moving the capture card to another PCI slot fixed it.  Another claimed getting the bleeding edge ivtv drivers to replace the kernel-provided ones worked.  (But I couldn't get these to compile - another issue, but I'm not too interested in that unless everyone here says that is the definite solution.)

So, any ideas?  


More information about the mythtv-users mailing list