[mythtv-users] FC8 --> F12 Upgrade: MythTV doesn't work with LIRC anymore - solved!

Andrew Junev a-j at a-j.ru
Fri Nov 20 16:29:21 UTC 2009

Friday, November 20, 2009, 6:14:41 PM, you wrote:

> The symlink shouldn't, in theory, matter. I'd be more inclined to
> think perhaps mythfrontend was trying to connect to
> /var/run/lirc/lircd. Can you remove the symlink, restart
> mythfrontend and see if its still working?

Yep! It works!
So MythTV is intelligent enough to determine a new location for LIRC
device? And I was stupid enough to change that location manually,
therefore getting a three-days fun trying to track it down... :(

>> A new issue is there though: each keypress on my remote now makes a
>> double action, for example a single press of "Down" key in the menu
>> moves the cursor two positions down. I think I had such a problem some
>> years ago when I was starting to set MythTV up for the first time. I
>> don't remember what was the reason for such a behavior exactly, but
>> I'll have a closer look at my lircd.conf file. I think the answer is
>> somewhere close now.

> You can add 'repeat=1' (or higher values as necessary) to each
> button config in your lircrc where you want repeats suppressed.

I think 'repeat=1' (or any other number) is supposed to turn repeats
on instead. Anyway, setting a 'delay=5' instead of 'delay=3' after
each 'repeat=1' actually solved my repeating problem as well.

So my remote is completely back now! :)

Thanks to all who commented and supported me in tracking this problem!
I really appreciate it, guys!

I will soon continue with the upgrade on the other machine:
mythbackend is next...

Best regards,

More information about the mythtv-users mailing list