[mythtv-users] FC8 --> F12 Upgrade: MythTV doesn't work with LIRC anymore

Jarod Wilson jarod at wilsonet.com
Fri Nov 20 15:14:41 UTC 2009

On Nov 20, 2009, at 10:08 AM, Andrew Junev wrote:

> Then I decided something could be wrong with '--output' option of
> LIRC. So I removed it, leaving just:
> LIRCD_OPTIONS="--driver=atilibusb"
> I restarted LIRC and made a symlink:
> ln -s /var/run/lirc/lircd /dev/lircd
> Just tried it with MythTV and ... IT WORKED !!!
> I really don't know why "--output=/dev/lircd" does not work as
> expected. Maybe it's a bug in LIRC, or maybe it has a real reason to
> be like that. Anyway, letting LIRC create default device and then
> symlinking to it seem to solve the problem!!!

The symlink shouldn't, in theory, matter. I'd be more inclined to think perhaps mythfrontend was trying to connect to /var/run/lirc/lircd. Can you remove the symlink, restart mythfrontend and see if its still working?

> A new issue is there though: each keypress on my remote now makes a
> double action, for example a single press of "Down" key in the menu 
> moves the cursor two positions down. I think I had such a problem some
> years ago when I was starting to set MythTV up for the first time. I
> don't remember what was the reason for such a behavior exactly, but
> I'll have a closer look at my lircd.conf file. I think the answer is
> somewhere close now.

You can add 'repeat=1' (or higher values as necessary) to each button config in your lircrc where you want repeats suppressed.

Jarod Wilson
jarod at wilsonet.com

More information about the mythtv-users mailing list