[mythtv-users] MythTV UPNP video with ac3 audo on PS3

Andre Newman mythtv-list at dinkum.org.uk
Thu Nov 19 14:16:11 UTC 2009

On 14 Nov 2009, at 12:36, Jiri Kraus wrote:

> Hello,
> i am running Kubuntu 9.10 with a mythtv-backend 0.22 (22814) latest
> packages from the avenard repository to record TV with my DVB-C Card
> and use it as a upnp Server. As a front end i am using a ps3 slim with
> firmware 3.01. According to the ps3 manuals it should be able to play
> ac3 multichannel audio from mpeg2 transport and program streams. In
> general every thing works flawlessly out of the box, so thanks to the
> developers of mythtv. My problem is that if i play a recorded tv Show
> via upnp on my ps3 i can only see the first audio stream (which is
> mpeg 2 stero audio) if the tv show comes with ac3 multichannel audio
> it is usually the third stream. I don't have an option to change the
> audio stream on the ps3.

I use a similar setup, there is an audio track select button on the bluray player remote for the PS3 or you can get this from one of the settings menus with a PS3 controller, triangle I think but I use a Harmony universal so I'm not sure. It may be that the PS3 doesn't recognise the AC3 track properly and so won't let you select it, this is annoyingly common, there are some windows fixer programs around for some of the common problems TSDoctor comes to mind but that's not really much of a solution.

Where in world are you and what channels do you have the problem with? With that info maybe someone can advise a work around or a solution.

I am in the UK and find ITV-HD has this problem sometimes but not others, BBCHD used to need a fixer but is now ok, the PS3 always selects the wrong audio first though. I have some recordings from HD Suisse which work fine and all the American ones I have CBS & WGBH work right first time too.


More information about the mythtv-users mailing list