[mythtv-users] Some Fanart not loading?

Robin Hill myth at robinhill.me.uk
Wed Nov 18 21:58:52 UTC 2009

On Wed Nov 18, 2009 at 12:24:55PM -0800, Robert McNamara wrote:

> On Wed, Nov 18, 2009 at 12:12 PM, Mark Greenwood <fatgerman at ntlworld.com> wrote:
> > Yes in my mind this is a big problem that ought to be addressed.
> Sorry, but as far as "big problems" go, this is way, way, way...
> way... WAY.... down the list.  There are real functional and setup
> issues that take a much higher priority than this kind of thing.  As
> ever, people writing code are stretched to the breaking point, and
> still doing it a) to work on what interests them, and b) for fun, and
> patches are always very gratefully received.
I've had a look into this issue, and it looks like it only occurs with
storage groups.  The code is checking modification times of both cache
and original files, and flushing older files from cache.  The problem is
that, with storage groups, the original file is remote so this lookup

This means the frontend will need to query the backend to retrieve the
modification time for every image from a storage group.  I'll have a
look into how to do this (looks like there's already a command to
retrieve that so there should be no need to bump versions).

    ( ' }     |       Robin Hill        <myth at robinhill.me.uk>  |
   / / )      | Little Jim says ....                            |
  // !!       |      "He fallen in de water !!"                 |
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 198 bytes
Desc: not available
URL: <http://mythtv.org/pipermail/mythtv-users/attachments/20091118/f1233207/attachment.pgp>

More information about the mythtv-users mailing list