[mythtv-users] HD-PVR blues and 0.22 - wrong video node

Bob Sully rcs at malibyte.net
Tue Nov 17 23:25:39 UTC 2009

Michael Drons wrote:
> This is my udev rule:
> SUBSYSTEM=="video4linux", ATTR{name}=="Hauppauge HD PVR", SYMLINK+="hdpvr"
> It creates a symlink as /dev/hdpvr to the video device.  I then use
> /dev/hdpvr in mythtv
> myth# ls -la /dev/hdpvr
> lrwxrwxrwx 1 root root 6 Nov  9 02:32 /dev/hdpvr -> video0
> Mike

Mike -

This seems to have solved it.  Also, another reason that the recording
failed was that I had left the "%s" after the channel-change command in
the Input Connections section (it had worked in 0.21; not sure why it
doesn't here); anyway, I removed it, added your rule (and changed the
entry in the Capture Cards section), rebooted the box, and I now have my
first in-Myth HD-PVR recording in progress, on the right channel, with a
thumbnail present in MythWeb.  Hopefully all's well!


Addendum:  The recording finished, and I just watched part of it. 
Beautiful quality, and really reasonable file sizes compared to the 4+ GiB
per hour I was getting by recording manually.

Kudos to the devs!  While there have been some ongoing upgrade issues,
probably some of which are peculiar to my setup, I'm really impressed with
this latest release so far.

Also, thanks very much to Mr. Avenard for his repo.  Excellent work; it
makes updates painless.  By the way, JYA, I just upgraded to your 190.42
nVidia package from 180.xx.  Nice!  It fixed a long-standing problem I've
had with occasional horizontal tearing that was NOT related to the
Compositing feature, since my Myth box runs WindowMaker and doesn't need

Thanks again to all!
Bob Sully - Simi Valley, California, USA

More information about the mythtv-users mailing list