[mythtv-users] nfs pauses

Yianni Vidalis yiannividalis at hotmail.com
Wed Nov 11 20:52:27 UTC 2009

First of all, thank you all for your input. 
Sorry it took me so long to post but I've been very busy. And please accept my apologies for the unnecessarily repeated posts, but either hotmail or the List had a problem while I was trying to post the first time.
Anyway, what I tried so far with the nfs server (opensuse): 
- I downgraded my opensuse 11.1 kernel to (I kept the .rpm) but the problem is still there. It is the kernel I am still running.
- I followed torbjorn.jansson at gmail 's suggestion about iptraf, but I had no success. Trying a similar approach, I tried pinging from the nfs server the frontend but no success, either. (by the way, my frontend is a debian Lenny system (2.6.26 kernel)).
- Reading myth at robinhill 's post I changed the fstab entry to rw,sync,hard. This is the best behaviour so far, meaning that the first pause occured 5 minutes into the video. I guess it's due to the increased {w,r}size. 
- Trying mail at benlancaster's suggestion: Sorry, but using the defaults doesn't work for me. The pauses occur very often.
- I even tried to decrease {w,r}size to 4096 and later to 2048 bytes. Still problem.
So far I am using the rw,sync,hard mount option, because it is the one with the least pauses. I will install the latest kernel as before since it doesn't seem to affect anything, and I will probably wait for opensuse 11.2 to come out (it is on T-18 today) which has kernel and other improvements. You see, I still think it's a nfs or kernel or network problem (can you imagine how I'll feel if I see a relevant commit in myth trunk? LOL)
Thank's again for your response,
Έχετε Messenger; Έχετε και Windows Live. Μάθετε περισσότερα.

More information about the mythtv-users mailing list