[mythtv-users] nfs pauses

Yianni Vidalis yiannividalis at hotmail.com
Tue Nov 10 20:07:58 UTC 2009


From: yiannividalis at hotmail.com
To: mythtv-users at mythtv.org
Date: Tue, 10 Nov 2009 20:18:57 +0200
Subject: [mythtv-users] nfs pauses

I am facing a strange problem lately and I hope someone here can provide some insight (or a solution....). 
Most of my videos are stored in an nfs share. The share is mounted in fstab using rw,rsize=32768,wsize=32768,bg. While watching them on my frontend, there are occasionally pauses, as if the file "is not there" when the frontend needs it. I notice it especially with films with AC3 sound because the "AC3" led on the amplifier is turned off momentarily. The nfs share is on an opensuse 11.1 pc, stored on raid 5 on top of lvm (talking about redundancy....). The strange thing is that I didn't always have this problem, it must have happened after one of the latest package upgrades, so I suspect something to do with the latest opensuse kernel ( x86_64). The ethernet card is an onboard gigabit, using the r8169 module. The frontend card is 100mbps (8139too module). 
I am running mythtv trunk, version 22772. I thought it might have been VDPAU, but disabling it made no difference. I am using Graphite, so turning off "Extra audio buffering" would not make any difference. I also tried with actimeo=0 and 5 and with the option completely removed. Same behaviour.
Using the system monitor on the nfs server, I noticed that that network throughoutput is non constant, but the videos are served in "peaks" around 20 secs apart. The pauses occur during these peaks, which are shorter and wider when a pause occurs. 
Watching part of a suspect video with xine was smooth, although I admit I watched only 5-6 minutes of it. Moving the file locally and watching it in mythtv shows no problems, either.
I have no other network problems between the two pcs, the ssh connections are never broken even after hours of idle time, file transfers are smooth and fast for 100mbps network. Is it true to suspect that some latency has increased, either on the filesystem or the network driver? Has anyone faced any similar problems? Can you please suggest a possible solution?
Thank you for a very great program, I am very happy that 0.22 is out, although I will continue to run trunk because now I'm ... addicted to it.
Thank you,

Following this up, I noticed that using xine, the program doesn't pause because it fetches data constantly. The network diagram is more like continuous waves than completely separate peaks, so the file is never "forgotten" by the filesystem / network (I again assume that this is that is causing it). Is there any way I can persuade mythtv to behave similarly or is this option (if it exists) hidden deeply in code that shouldn't be touched? (My C++ skills are zero, but I can change some line if you point me to it).
Thanks again,
Το What's New σας ειδοποιεί άμεσα για κάθε ενημέρωση. Μάθετε πώς.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mythtv.org/pipermail/mythtv-users/attachments/20091110/294ae29a/attachment-0001.htm>

More information about the mythtv-users mailing list