[mythtv-users] DB charset pre-conversion test failed! Your database seems to be partially corrupted.

Tom Dexter digitalaudiorock at gmail.com
Tue Nov 10 01:19:31 UTC 2009

On Mon, Nov 9, 2009 at 11:45 AM, Brian J. Murrell <brian at interlinx.bc.ca> wrote:
> On Mon, 2009-11-09 at 11:36 -0500, Tom Dexter wrote:
>> If we're talking about tables that just happen to be missing from a
>> database crash or whatever, what kind of warning could they give ahead
>> of time?  "If your database is hosed the upgrade won't work"?  I'm not
>> sure what you expect there.
> How about "Database upgrade failed.  Table XYZ is missing." rather than
> what it's doing now which essentially takes you down the mis-matched
> character-set path which, has nothing to do with missing tables.
>> I'm not sure what "wild goose chase" you're referring to.
> The wild goose chase of attempting to fix a mis-matched character-set
> "corruption" when that's not what the problem is.
>> That
>> database corruption issue due to connection default character sets is
>> far from a wild goose chase.
> It is a wild goose chase when "connection default character sets" has
> got nothing to do with the actual failure.
>> It's something that affects all Gentoo
>> users like myself for one thing.
> That's fair enough.  If that's what the problem really is.
>> MythDVD has been gone for some time now hasn't it?
> In 0.21?  If it "went away" during the 0.21 release cycle, nobody told
> me.
>> I'll compare it to mine when I get home.
> Much appreciated.  Many thanx!
> b.

Interesting...the only differences between your list of tables and
mine is that yours has a number if tables that aren't in mine because
of plugins you're using that I'm not.  So in short, it doesn't seem to
me that your backend schema upgrade is breaking because of missing


More information about the mythtv-users mailing list