[mythtv-users] DB charset pre-conversion test failed! Your database seems to be partially corrupted.

Brian J. Murrell brian at interlinx.bc.ca
Mon Nov 9 13:54:08 UTC 2009

On Sun, 2009-11-08 at 22:25 -0500, Michael T. Dean wrote: 
> Most likely the same problem as: 
> http://www.gossamer-threads.com/lists/mythtv/users/406111#406111 (which 
> was missing tables).  Same solution, too.

OK.  I really, really, hate to have to lose all of the settings that I
have spent literally years honing and fine-tuning.

Why doesn't the usual database schema upgrade handle this in a more
graceful, less destructive manner?

Is there something I can while running my 0,21-fixes system to prevent
this on upgrade?  You say the problem was simply missing tables (but I
couldn't find reference to which ones).  Can't I just simply create them
before doing the upgrade?  Will installing certain myth
components/packages create the needed and missing tables?  I'm most
willing to do that.

This really is a bug that needs to be fixed in the upgrade, IMHO.  I am
at least the second person to run into it and making people have to grub
through the database and lose all of their setting just to upgrade is
not nice.


-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 197 bytes
Desc: This is a digitally signed message part
URL: <http://mythtv.org/pipermail/mythtv-users/attachments/20091109/433aecaf/attachment.pgp>

More information about the mythtv-users mailing list