[mythtv-users] upgrade problems with repositories

Johnny jarpublic at gmail.com
Wed Nov 4 19:44:38 UTC 2009

>  Depends: mythtv-database (=0.22.0+fixes22594-0ubuntu1) but
> 2:0.21.0+fixes-22228-openglvdpau2-0ubuntu1 is to be installed

It looks like you are having issues because you have the mythbuntu
9.10 repositories and JYA's .21 backport both enabled. So it is trying
to install .22 from the mythbuntu repository but the .21 from JYA's
has a higher priority or a dependency issue.

You can confirm this by checking the output of "apt-cache policy
mythtv-database". That will show the priority given to the packages
from the different repositories.

Either way I think (but and not certain) you have two options disable
JYA's and go with mythbuntu. Or you can add in JYA's testing
repository where he has .22-fixes. The latter is what I am using. Also
JYA packages mythtv and the nvidia drivers a little differently. He
does it according to the nvidia specs and mythbuntu hasn't done this
yet. The recommended way allows you to switch nvidia drivers without
reinstalling mythtv. So I use the nvidia drivers from his repository
as well just to keep everything neat and in sync.

> Depends: mythtv-frontend but it is not going to be installed
> Depends: mythtv-backend but it is not going to be installed
> I assume this is repositories problem now?
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users

More information about the mythtv-users mailing list