[mythtv-users] HD-PVR giving up

Marius Schrecker marius at schrecker.org
Tue Nov 3 07:09:42 UTC 2009

> >On Tue Nov  3  5:32 , Kenneth Emerson <kenneth.emerson at gmail.com> wrote:On Fri, Oct 30, 2009 at 3:29 PM, Ron Garrison <ron.garrison at gmail.com> wrote:
>>You could try setting the hdpvr_debug level in the kernel level
>>options to see if dmesg might give you some info.
>>I just got my hdpvr working last night, and the little I've played
>>with it it seems to be working quite well.  I compiled from the
>>22-fixes branch which I updated last night.  What I learned along the
>>way (which probably has no bearing on your issue, but you never know -
>>it might trigger something to try).
>>If you have SP/DIF selected, but your optical is not hooked up (or you
>>hooked it to the output instead of the input like I did), the
>>recording will fail.
>>The patches mentioned on the wiki page turned out to be very important
>>for me.  Without the patches, It would work until I changed a channel.
>> Not sure if mythbuntu incorporates these or not.
>>I have my box set at 720P I believe (I did this a long time ago and
>>haven't gone back to verify), but the wiki indicates this should no
>>longer be an issue.  I was planning on experimenting this weekend.
>>I am using VDPAU and haven't tryed without.  It was so easy to setup
>>and worked out of the box.  I'm running an i5 (2.66 GHz) and during
>>live TV I get 1 to 2% CPU usage on one of the CPUs.
>>Hopefully something will point you in the right direction.  Good luck.
>I just wanted to add my 2 cents in here with my experience with the HD-PVR.  I've been trying to get this working for about 4 weeks (not solid, I have been using the firewire successfully in the interim).  I had a fairly recent firmware >installed out of the box (0x0f), but try as I might using the information in the HD-PVR wiki, the backend would fail on all recording attempts.  I started over by upgrading the firmware at Hauppaugue web site.  It now sits at 0x12.  >After >re-adding the HD-PVR to the backend, I actually got a recording to be made with no errors in the log file; however, the recording itself was unwatchable.  The recording would "stutter"; it would play fine for 2-5 seconds then >stop as >if it had been paused on a single frame for 1-2 seconds and then repeat.  After searching the recent posts and finding your post, I decided to go back and change the output of my DCH3200 to 720p (it was at 1080).  I had >left it at >1080 because, as you pointed out, the wiki said this step should no longer be required.  I am here to say that when I changed to 720, not only did I get no errors while recording, but the playback was flawless.  So I would >say, at >least in my case, 720p output is required.
>-- Ken _______________________________________________

Thanks Ken,

Interesting what you said about the firmware number and re-adding the hd-pvr. 720p is the only format being output by my cable box, so that's at least one thing that shoudl be correct.  I haven't had time to re-check my firmware yet, due to very low WAF, and box being connected to the TV which is in constant evening use by the family.

Next things for me to try (in order), are:
revert again to rca (I somehow messed up even more last time I tried this, but haven't managed to undo the damage yet, so will revert again)
 re-install the firmware from a windows VM
double check the permissions and paths in my storage groups
set /dev/video0 permissions to 777
enable vdpau playback (I didn't really want to do this before I had the setup working with cpu+, as it's another unknown, but hey, what can I loose?)
Reinstall the whole sjabang :-(

At the current rate this list will take me several weeks, all in the face of steadily falling WAF, so I really hope one of the first steps does it for me.



More information about the mythtv-users mailing list