[mythtv-users] Long delays with remote occasionally

Tom Dexter digitalaudiorock at gmail.com
Fri May 22 12:42:14 UTC 2009

On Thu, May 21, 2009 at 11:00 AM, Allen Edwards
<allen.p.edwards at gmail.com> wrote:
> A month ago I implemented the wonderful patch that Josh provided.  It
> worked perfectly for a solid month but now, without doing any system
> updates or changes, I am getting pauses on "skip forward" commands of
> perhaps 5 seconds.

Prior to Josh's patch I had _serious_ delay problems...occasionally
delaying for minutes.  There's no question that his ffmpeg patch
addressed the bulk of the problem.  As I posted earlier, I still
occasionally (though rarely) get minor delays with the remote...maybe
5 to 10 seconds but they're rare, and for whatever reason, only when
720p recordings (ABC or Fox).  Since the last post I made I've
upgraded the frontend and backend to rev 20500 of 0.21-fixes but I
still get this occasionally.

I still think all of this is related to xorg-server 1.5.x.  Most
people on this thread started getting the issue after (for example)
upgrading Fedora, which included that xorg upgrade.  In my case, it
started after a Gentoo upgrade where xorg-server was in fact the
_only_ upgrade that wasn't trivial.  The ffmpeg issue that Josh's
patch addressed was obviously there for a long time and, at least in
my case, caused no problems prior to the xorg upgrade.

By the way...an unrelated note on the timing method:  I've had to
switch from OpenGL vsync to RTC due to occasional black screen lockups
using OpenGL vsync with newer nVidia drivers.  I can't see any visible
difference using RTC.  Others here have noted similar problems with
OpenGL vsync (Yeechang Lee for one).


More information about the mythtv-users mailing list