[mythtv-users] Cannot find tmdb.xml (error w/tmdb script on lookup in MythVideo)

Michael T. Dean mtdean at thirdcontact.com
Thu Jun 25 19:42:54 UTC 2009

On 06/25/2009 03:35 PM, Brad DerManouelian wrote:
> On Jun 25, 2009, at 12:31 PM, Michael T. Dean wrote:
>> On 06/25/2009 03:17 PM, Bobby Gill wrote:
>>> Just got this dialog in the FE:
>>> "Could not find tmdb.xml in /usr/share/mythtv/mythvideo/scripts at 
>>> /usr/share/mythtv/mythvideo/scripts/tmdb.pl line 304
>>> Check VideoManager Settings"
>>> I just reinstalled the script from the wiki page to be sure it was 
>>> up to date, and it same thing...
>> That happens when you get absolutely no response from the website.  
>> Generally, it happens with name-resolution problems.  Often, when you 
>> execute the search a second time, it just works.
> I'm having this problem a lot lately. I couldn't get back a response 
> for "Minority Report" (and many other variations of that text) even 
> thought it's in the database.

Ah, the same thing also happens when the TMDb website is having issues.  
It seems they've been having a lot of database issues, lately.  Or, 
perhaps it's just that the site is overloaded.  (I've heard a lot of 
programs that use it are not storing information locally, but just 
hitting it every time info is needed.)

> Based on some messages I found in the archives I tried others manually 
> from the command line. I found that -M "hulk" worked fine, but -M 
> "Hulk" did not. I think something has changed and the script needs 
> updating but no idea what that might be. 

The script in trunk (which you get when you re-run the instructions from 
the wiki - ) has all the patches that fix all the reported bugs 
(including your Hulk bug).  The only patch left just changes the error 
you're seeing to a nice, human-readable message.  


More information about the mythtv-users mailing list