[mythtv-users] Update to lirc 0.8.5 breaks things

Jarod Wilson jarod at wilsonet.com
Sun Jun 21 03:20:48 UTC 2009

On 06/20/2009 11:06 PM, Richard Shaw wrote:

>         and now my
>         remote doesn't work. This configuration has worked flawlessly since
>         Fedora 8. I'm now getting some output from dmesg I don't
>         remember seeing
>         before:
>         [root at calvin ~]# dmesg | grep lirc
>         lirc_dev: IR Remote Control driver registered, major 61
>         lirc_serial: auto-detected active low receiver
>     Do you know if it was auto-detected as active low previously?
>     Definitely makes a difference... You could try forcing it to active
>     high as a test. (add modparam 'sense=0')
> Not sure but tried sense=0 (i.e. "modprobe lirc_serial sense=0" if
> that's the correct way to do it) and didn't see anything different in
> dmesg. It still said "low".

Hrm. That certainly shouldn't be the case... You did unload the 
lirc_serial module before that, right? What you should be seeing (in 
dmesg) is:

lirc_serial: Manually using active high receiver

>     Load lirc_serial with the module param 'debug=1', see what else it
>     says. You can try fiddling with other module options as well.
> I didn't see anything helpful but here's the output:

The output from modprobe isn't what's interesting, its the stuff that 
gets spewed into dmesg afterwards when trying to use it. :)

> Since "irw" didn't work I tried stopping the service and running
> irrecord to make sure it wasn't my remote config but it had an issue as
> well:
> [root at calvin modprobe.d]# irrecord test
> irrecord -  application for recording IR-codes for usage with lirc
> Copyright (C) 1998,1999 Christoph Bartelmus(lirc at bartelmus.de
> <mailto:lirc at bartelmus.de>)
> irrecord: could not get hardware features
> irrecord: this device driver does not support the LIRC ioctl interface
> irrecord: make sure you use a current version of the driver
> irrecord: could not init hardware (lircd running ? --> close it, check
> permissions)

Hrm... That's not looking particularly good... I may have vague 
recollections of Janne saying that was known to be busted though, even 
when the receiver is working properly. I really do need to dive into 
lirc_serial code again, but its... grotty...

For the record, what kernel version is this with? Need to compare the 
lirc_serial code in it w/current cvs and git trees...

Jarod Wilson
jarod at wilsonet.com

More information about the mythtv-users mailing list