[mythtv-users] Update to lirc 0.8.5 breaks things

Richard Shaw hobbes1069 at gmail.com
Sun Jun 21 03:06:10 UTC 2009

On Sat, Jun 20, 2009 at 11:12 AM, Jarod Wilson <jarod at wilsonet.com> wrote:

> On 06/20/2009 10:37 AM, Richard Shaw wrote:
>> I wanted to see if anyone else was affected by this. I just updated my
>> Fedora 10 Myth box (x86_64) and my lirc got updated to 0.8.5
> That's irrelevant, actually. Its the kernel module that matters here, not
> the userspace portion. What kernel version? Looking at lirc_serial more is
> on my TODO list for next week...
>  and now my
>> remote doesn't work. This configuration has worked flawlessly since
>> Fedora 8. I'm now getting some output from dmesg I don't remember seeing
>> before:
>> [root at calvin ~]# dmesg | grep lirc
>> lirc_dev: IR Remote Control driver registered, major 61
>> lirc_serial: auto-detected active low receiver
> Do you know if it was auto-detected as active low previously? Definitely
> makes a difference... You could try forcing it to active high as a test.
> (add modparam 'sense=0')

Not sure but tried sense=0 (i.e. "modprobe lirc_serial sense=0" if that's
the correct way to do it) and didn't see anything different in dmesg. It
still said "low".

>  lirc_dev: lirc_register_plugin: sample_rate: 0
>> lirc_serial: ignoring spike: 1 1 4a3cdfee 4a3cdfee 9b369 9b335
> ...
>> lirc_serial: ignoring spike: 1 1 4a3ce029 4a3ce029 68aca 68a93
>> Anyone have any suggestions?
> Load lirc_serial with the module param 'debug=1', see what else it says.
> You can try fiddling with other module options as well.

I didn't see anything helpful but here's the output:

[root at calvin ~]# modprobe -v -r lirc_serial
[root at calvin ~]# modprobe -v lirc_serial debug=1

install /bin/setserial /dev/ttyS0 uart none ;    /sbin/modprobe
--ignore-install lirc_serial
irq=4 io=0x3f8

My modprobe.conf (pretty much exactly as what's on your Fedora Mythology

alias char-major-61 lirc_serial
# Lirc module settings
options lirc_serial irq=4 io=0x3f8
install lirc_serial /bin/setserial /dev/ttyS0 uart none ;\
    /sbin/modprobe --ignore-install lirc_serial

Since "irw" didn't work I tried stopping the service and running irrecord to
make sure it wasn't my remote config but it had an issue as well:

[root at calvin modprobe.d]# irrecord test

irrecord -  application for recording IR-codes for usage with lirc

Copyright (C) 1998,1999 Christoph Bartelmus(lirc at bartelmus.de)

irrecord: could not get hardware features
irrecord: this device driver does not support the LIRC ioctl interface
irrecord: make sure you use a current version of the driver
irrecord: could not init hardware (lircd running ? --> close it, check

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mythtv.org/pipermail/mythtv-users/attachments/20090620/7a37c4ef/attachment.htm>

More information about the mythtv-users mailing list