[mythtv-users] Zotac ION / no video using DVI/HDMI and nvidia driver

Frank Merrill fmerrill1 at gmail.com
Tue Jun 9 02:57:11 UTC 2009

>> I can think of a few scenarios that your hardware checks may not have
>> covered. Have you tried taking it back to your monitor to see if it
>> /still/ works there?

>yup - plugged the HDMI into the monitor - and desktop was there in all its
>1080p glory

>> Have you tried a different input on the TV
>> (assuming it has more than one HDMI input)?

>yes - I have two HDMI inputs - it's the same result on both.  And same
>result if I connect the DVI out to either HDMI port.  Interestingly enough
>the TV is picking up that there is a signal and shows on the OSD -
>1080x1020p 60HZ.  And if I try another resolution in xorg (from the EDID) it
>will reflect that resolution on the OSD - just blank screens in all cases
>which suggests the card and TV are definitely speaking to each other.

>> Does your Mac Mini still
>> work on the TV (I think you did this to look up the modeline but it
>> wasn't explicitly clear)?

>Yes - mac mini (its the older Core Duo model) connected to the TV with the
>DVI connected to the HDMI input.  Works fine, and drives the TV at 1080p.
> So the TV is clearly capable of accepting a digital signal from a computer.
> Before I install the nvidia drivers and are running with just the VESA
>drivers - the nvidia card works just fine on the TV as well.

>Have you tried VGA/component (assuming the
>> Ion boards and your TV have either of those)?

>Yes- VGA works...it didn't drive at 1080p initially because the nvidia card
>wasn't reading the EDID.  But taking the EDIDs that I was picking up from
>the HDMI connection and putting them in xorg.conf meant that VGA works fine.
> But I really need HDMI audio working since that was one of my primary
>reasons for picking up an ION.

>> Have you done anything
>> in particular to enable HDMI audio?

>Initially all I needed to do on Ubuntu 9.04 was go into alsamixer, unmute
>one of the digital outs, and everything 'just worked'

>> If there's something special to do
>> focus on getting just the video working and leave audio out for now.

>Agreed.  I reinstalled 9.04 from scratch and left everything bog-standard
>except for the nvidia drivers.  I also tried 8.10 - but same result.

>> From the driver side: Are you able to get to a TTY/shell locally and
>> bring it up on the TV (ctrl+alt+F1 to switch to TTY login and
>> ctrl+alt+F7 to get back to GDM/KDM/X on most systems) or are you able
>> to ssh into the box?

>Yes - I can get back to a TTY shell with ctrl-alt-F1.  I can also ssh in
>just fine.

>> Is the nvidia module actually installed and is
>> the module loading correctly (lsmod | grep nvidia)? Since it was
>> working on your monitor seems like it should be loading the driver.
>> I've seen X fall back to the default driver when my proprietary ATI
>> driver wasn't correctly installed on one of my systems so maybe this
>> is happening and perhaps the vesa driver is not be smart enough to
>> detect your TV to run the supplied modeline. That's just speculation.

>Yes - I'm definitely running the nvidia driver - output of lsmod:
>vidia               9550692  26
>agpgart                42696  1 nvidia

>RG Newbury wrote:

>> You might check in the BIOS for the Zotac to see whether there are any
>> video output choices. It certainly sounds like the board turns on VGA output
>> by default, but not HDMI.

>I have fiddled with the BIOS options - but everything just works fine on my
>computer monitor connected using HDMI.

>Thanks guys - I've tried every xorg.conf option I can think of, but fear
>that the unique combination of this board and my TV weren't destined for
>each other!

First, you can get a TTY by changing to one, which means your HDMI
output is definitely working to that TV.
Unless I missed it, the one thing you haven't mentioned is if your TV
supports HDCP or not.
The Mac Mini doesn't do HDCP to the best of my knowledge, and so a
non-HDCP TV should work fine with it.
The Zotac is HDCP compliant though, and if your TV isn't HDCP
compliant, maybe that is the issue?
VGA would work, because there is no HDCP across that.

I wouldn't have even thought HDCP would be any issue for the desktop,
just for content with HDCP on it, but, I'm just guessing anyway.
Is there anything in the Zotac BIOS to turn off HDCP?

Good Luck!

More information about the mythtv-users mailing list