[mythtv-users] Problem with logitech remote on menus

Steve V olivuts at yahoo.com
Sat Jun 6 20:00:47 UTC 2009

----- Original Message ----
> From: David Snider <dsnider at thesniderpad.com>
> To: Discussion about mythtv <mythtv-users at mythtv.org>
> Sent: Sunday, 7 June, 2009 1:48:21 AM
> Subject: Re: [mythtv-users] Problem with logitech remote on menus
> On Jun 6, 2009, at 5:54 AM, Steve V wrote:
> > 
> > I have just changed to a Logitech Harmony remote. My receiver is a Soundgraph 
> imon.
> > 
> > The remote seems to mostly work OK except when I am accessing on screen menus.
> > 
> > For example if I am watching a recording and I press menu then up or down 
> buttons to get to advert auto skip, then right button to get submenu, the 
> submenu shows up - so far the up and down buttons have worked exactly as I would 
> expect.
> > 
> > If I now push up or down (with the submenu still showing) the submenu 
> dissapears and the recording jumps back or forward. This is the behaviour I 
> would expect if the submenu was not on the screen and I pushed up or down.
> > 
> > I have tested with the keyboard it all works fine and I have tested with the 
> original imon remote and all works fine.
> > 
> > It seems almost as though the logitech remote is sending escape before the up 
> or down. But it doesn't seem possible as the up and down work perfectly well 
> when used in the non on screen menus - for example when changing settings - when 
> not watching a recording. It appears that this behaviour only occurs in submenus 
> while watching a recording - possibly also while watching live TV though I 
> didn't think to test this before turning off the system.
> > 
> > Can anyone think of a logical solution to this problem?
> > 
> Not a solution, yet, but have you logged in from a terminal and run "irw" to 
> watch what buttons the lirc daemon is seeing? 
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users

Great idea, just tried irw. The logitech send the correct command only thing is it sends it twice. That shouldn't matter as 2 ups would just move me up 2 menu items. Also interestingly it actually doesn't move 2 menu items, basically either Myth or Soundgraph receiver is ignoring the second identical command. When I use the direction buttons I only get one movement per push.

The problem is only in the Myth submenus.

I tried a different test. I used the Logitech remote to get to the submenu then I picked up the imon remote and pushed up and down a few times. This did the expected scroll up and down through the submenu. While the submenu was still on the screen I picked up the logitech and pushed up and down and it worked perfectly.

I can recreate this situation at will, everytime if I only use the Logitech, it jumps out of the submenu, while the imon does not, then if I use the logitech after the imon the logitech works fine for that instance.

Got me baffled, it doesn't seem to be a problem with the logitech setup. 


More information about the mythtv-users mailing list