[mythtv-users] Upgrade irblaster LIRC Woes (but fixed watching live tv)

Nick Morrott knowledgejunkie at gmail.com
Tue Jun 2 23:06:35 UTC 2009

On 02/06/2009, Edward Brookhouse <ebroo at healthydirections.com> wrote:

> I’ve managed to get everything back up and running except my irblaster. Over
> two weeks I have tried everything up to replacing the blaster itself because
> I couldn’t see it emitting any IR.

If you have a digital camera/camcorder, you may well be able to see
the IR emissions by looking through the viewfinder.

>  Still no joy – all modules load fine, /dev/lircd1 gets created by

Do you mean /dev/lirc1?

> lirc_serial as it should, but irsend never actually seems to transmit
> anything from the blaster. The serial ports worked before I rebuilt the OS,
> but can anyone offer any additional thoughts on troubleshooting?

First things first:

i) I'm guessing you're running another instance of lircd for your
remote control. Which kernel module is it using, and is it working

ii) For the second instance of lircd running to control the blaster,
which driver, device and socket are you using?

iii) What modprobe entries do you have (e.g. are you running setserial
to release the COM port, is lirc_serial configured with the correct

iv) Is the remote definition for the blaster in /etc/lircd.conf?

v) Do you see any LIRC messages in the syslog? Does irsend give any
errors when run? What about the blaster's lircd process when run from
the command line?

vi) What are the permission on your LIRC devices?

# ls -la /dev/lirc*


Nick Morrott

MythTV Official wiki:
MythTV users list archive:

"An investment in knowledge always pays the best interest." - Benjamin Franklin

More information about the mythtv-users mailing list