[mythtv-users] OT: SATA errors

Harry Devine lifter89 at comcast.net
Thu Jul 9 00:54:53 UTC 2009

George Mari wrote:
> Harry Devine wrote:
>> I know this is off-topic, but I figured someone here would know.  My 
>> Myth MBE (Mythbuntu 8.10 x86_64) seems to be in a really bad state 
>> right now.  It was fine last night, but tonight I noticed that when I 
>> was SSH'd in, I was getting errors suddenly about the file system 
>> being read-only.  So I figured I'd reboot.  When I did, I got some 
>> messages about having to run fsck manually, and every service that 
>> tried to start would error out saying that the service user didn't 
>> exist (like "www-apache" for example).
>> I was able to get the box to come up in rescue mode and I ran the 
>> fsck option that came up.  When I did, I started seeing errors like 
>> the following:
>> ata1.00: exception Emask 0x10 SAct 0x6 SErr 0x90202 action 0x3 frozen
>> ata1.00: irq_stat 0x01400000, PHY RDY changed
> I saw this error on a brand-new frontend I built last year.  Turned 
> out to just be a loose SATA cable.  Make sure yours are plugged in 
> all-the-way, on both ends.
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
I just checked that, and even replaced the SATA cables on both drives.  
I also moved them from SATA 1 & 2 to SATA 3 & 4 on the motherboard.  
Same issues.  I know that my OS was on /dev/sda (partitions sda1 -> 
sda7).  I am booted off of the Mythbuntu 8.10 LiveCD right now, and 
wanted to do a check on the hard drives.  It keeps telling me that 
either I have to be root to do that or the device is busy.  How can I 
run fsck in this case to check the drives?


More information about the mythtv-users mailing list