[mythtv-users] long delays responding to keystrokes and ir events

Michael T. Dean mtdean at thirdcontact.com
Tue Jan 6 17:17:14 UTC 2009

On 01/06/2009 10:06 AM, nospam312 wrote:
>> I recently updated to build 19538 that is available in the mythbuntu
>> repository, and I am still having the same issue. The only other suggestion
>> I have seen was to enable the "UseEvents" option in my xorg.conf file. But
>> that didn't seem to fix things for me. I am still frequently getting delays
>> of 20 or 30 seconds with no response and then everything starts working
>> smoothly again.
> Not much help but the delays I was having with the previous build seem
> to have been solved for me so far but I have not been using this
> release for long so I may not have noticed.

Are you (both those with the issue and those for whom the issue has 
cleared up) running gnome-screensaver?

With r19222, we only run gnome-screensaver-command once every 30 seconds 
at most and only if gnome-screensaver is running (with prior versions, 
we attempted to run it on every remote keypress--whether 
gnome-screensaver was running or not) and it seems that either the 
buildup of system calls or gnome-screensaver-command itself caused the 
issue.  So--if it's just gnome-screensaver-command causing the 
problem--you could still get the delay once every 30 seconds or so, but 
only if you're running gnome-screensaver.

> Check mythbackend --version and in the Status menu of mythfrontend to
> ensure you are actually using the latest build.

Good advice.  It is >19222, right?


More information about the mythtv-users mailing list