[mythtv-users] HD-PVR driver /dev/videoX issue

Bob Sully rcs at malibyte.net
Wed Feb 18 05:10:09 UTC 2009

Hi all -

I recently updated my Ubuntu Hardy Myth box to the latest available
kernel, as I'd like to get the newest available nVidia driver updates via
the ubuntu-restricted-modules package.  Yeah, they're still way behind the
curve (still using 169.12), but I figure that I'll eventually get the
binaries with the VDPAU updates for both the nvidia drivers and mplayer,

Anyway, afterward, I compiled the latest HDPVR driver from:
http://hg.jannau.net/hdpvr - just so I can record HD from the STB
(manually, from the CL at this point, since I'm not running trunk).  It
worked fine with the previous kernel.

The compile went fine, but I'm having issues getting it to create
/dev/video1 (/dev/video0 is being used for something else).  Previously, I
had put the following in /etc/rc.local, and it had worked OK:

# HD-PVR Options
modprobe hdpvr video_nr=1
v4l2-ctl --device=/dev/video1 --set-ctrl=video_bitrate=9000000
v4l2-ctl --device=/dev/video1 --set-ctrl=video_peak_bitrate=11000000

This no longer works:

[mythtv at vader: ~]$ lsl /dev/video*
crw-rw----+ 1 root video 81, 0 2009-02-17 20:44 /dev/video0

The module is being loaded:

[mythtv at vader: ~]$ lsmod | grep hdpvr
hdpvr                  30344  0
v4l2_common            20992  3 hdpvr,tuner,cx8800
videodev               48896  5 hdpvr,tuner,cx8800,cx88xx,v4l2_common
i2c_core               28544  12
usbcore               170288  7 hdpvr,lirc_imon,usbhid,ehci_hcd,uhci_hcd

Can someone clue me in on a fix?

Bob Sully - Simi Valley, California, USA

More information about the mythtv-users mailing list