[mythtv-users] Mythtv backend setup crashes when trying to configure Gigabyte GT-U8000-RH USB Tuner

Brad O'Connor oconnor.brad at gmail.com
Mon Dec 28 03:14:19 UTC 2009

I've just tried adding one of these tuners as a 3rd tuner on my freestanding
backend (running Mythbuntu 0.22 on Karmic with Avenard repositories).
According to http://www.linuxtv.org/wiki/index.php/DVB-T_USB_Devices this
device should work out of the box with kernel support since 2.6.28 (I'm on
2.6.31-16-generic). It seems to be being recognised and the required drivers
seem to be present (the files dvb-usb-dib0700-1.20.fw and xc3028-v27.fw are
present in /lib/firmware. dmesg shows the following during startup (this was
taken during a startup with my 2 existing tuners removed (both Winfast
DTV-2000H PCI cards).

[   27.329939] dib0700: loaded with support for 9 different device-types
[   27.330223] dvb-usb: found a 'Gigabyte U8000-RH' in warm state.
[   27.330273] dvb-usb: will pass the complete MPEG2 transport stream to the
software demuxer.
[   27.330701] DVB: registering new adapter (Gigabyte U8000-RH)
[   27.673131] DVB: registering adapter 0 frontend 0 (DiBcom 7000PC)...
[   27.681629] xc2028 1-0061: creating new instance
[   27.681633] xc2028 1-0061: type set to XCeive xc2028/xc3028 tuner
[   27.681712] input: IR-receiver inside an USB DVB receiver as
[   27.681760] dvb-usb: schedule remote query interval to 50 msecs.
[   27.681765] dvb-usb: Gigabyte U8000-RH successfully initialized and
[   27.683710] usbcore: registered new interface driver dvb_usb_dib0700

ls /dev/dvb returns


So, the dongle itself seems to be working and recognised (correct me if I'm

Now when I try go into MythTV backend setup (with all other cards removed) I
don't get very far. When I go into capture cards I am able to find a DiBcom
7000PC DVB capture card which I install. I then go to Input connections and
select this card. I enter a Display Name (Tuner 1) and select the EIT as my
Video Source. I then select Scan for channels and start a scan with my usual
settings (Desired Services = TV, Only Free checked, Test Decryptability
unchecked, Scan Type = Full Scan, Country = Australia). I then start the
scan and I get the scanning screen but nothing happens. If I try to cancel
or stop the scan, the backend setup crashes and I have to kill it. The next
time I run backend setup it will crash fairly readily until I delete this
tuner and start all over again.

Does anyone have any ideas what is happening here. One thing that concerns
me is that the box is labelled as U8000 ver 2.0. I haven't seen any
references to the 2.0 online so far. However lsusb returns

Bus 001 Device 002: ID 1044:7002 Chu Yuen Enterprise Co., Ltd

which is the same as is listed on the linuxtv wiki.

Any ideas? Thanks.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mythtv.org/pipermail/mythtv-users/attachments/20091228/bd770776/attachment.htm>

More information about the mythtv-users mailing list