[mythtv-users] Rebuilding seektable for nuvexported videos not working

Ian Forde ianforde at gmail.com
Tue Dec 15 02:15:38 UTC 2009

On occasion, I've been known to use nuvexport to export movies.  Once
I've exported them, it turns out that I need to rebuild the seektable
via the following command:

mythcommflag --rebuild --video <moviename>.avi

Unfortunately, this no longer works for me.  When I take a look at the
filemarkup table after running the command, I only see a single line
about the video.  For example:

filename: features/incoming/The Visitor.avi
mark: 91
offset: NULL
type: 2

I've tried this from my Ubuntu 9.10 backend, and got these results.  So
I figured maybe it's the broken ffmpeg that comes with it that's causing
the failure.  (This is why I'm using a CentOS box to do my nuvexport
work for now until I get a better ffmpeg built on ubuntu.)

So I tried it on CentOS 5.4.  No joy there either.

Here are the last few lines from (as lifted from mc.out):

mythcommflag -v all --rebuild --video "The Visitor.avi" >& /tmp/mc.out

2009-12-14 18:17:36.691 MSqlQuery::exec() "SELECT data FROM settings
WHERE value = 'defaultccmode' AND hostname = 'kamino.iforde.net'"
2009-12-14 18:17:36.692 MSqlQuery::exec() "SELECT data FROM settings
WHERE value = 'defaultccmode' AND hostname IS NULL"
2009-12-14 18:17:36.692 NVP(0): LoadFilters(''..) -> 0x0
2009-12-14 18:17:36.693 NVP(0): ClearAfterSeek(1)
^H^H^H^H^H^H^H^H^H^H^H2009-12-14 18:18:04.724
2009-12-14 18:18:04.724 MSqlQuery::exec() "SELECT DISTINCT dirname FROM
2009-12-14 18:18:04.725 MSqlQuery::exec() "SELECT DISTINCT data FROM
settings WHERE value = 'VideoStartupDir';"
2009-12-14 18:18:04.725
Visitor.avi) = 'features/incoming/The Visitor.avi'
2009-12-14 18:18:04.726 MSqlQuery::exec() "DELETE FROM filemarkup WHERE
filename = 'features/incoming/The Visitor.avi' AND type = '9';"
2009-12-14 18:18:04.751 ~VideoOutputNull()

Finished commercial break flagging at Mon Dec 14 18:18:04 2009

Any thoughts?


More information about the mythtv-users mailing list