[mythtv-users] VDPAU package problems 0.22?

Jack Perveiler perveilerj at gmail.com
Sat Dec 5 01:35:40 UTC 2009

> >
> > I encountered/figured this out just the other day.  See my last few posts
> > here:
> >
> > http://ubuntuforums.org/showthread.php?t=1312985&page=5
> >
> > Basically, just force the version on 3 packages and THEN follow JYAs
> > instructions.
> >
> Thanks Jack,
> I came across that post, in fact it was the *only* return I got in
> google from my query :)
> I tried forcing but I'm not sure I was doing it right, can you supply
> the command please for the
> packages I need to force upgrade?
> I tried:-
>  apt-get install nvidia-glx-185 -f
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> nvidia-glx-185 is already the newest version.
> You might want to run 'apt-get -f install' to correct these:
> The following packages have unmet dependencies.
>   libmyth-0.22-0: Depends: libvdpau1 (>= 0.3) but it is not going to
> be installed
>  mplayer: Depends: libvdpau1 (>= 0.3) but it is not going to be installed
> E: Unmet dependencies. Try 'apt-get -f install' with no packages (or
> specify a solution).

I used synaptic.  Just selected the package (like nvidia-glx-185), then
clicked the package menu option.  About halfway down was a "force version"
option.  I clicked it and it let me choose the version I wanted.  After I
did that for all three packages and "apply"ed them I went to the same
packages menu and selected "lock version".  Synaptic wanted to upgrade them
again right after I downgraded (since I was now using "out-of-date"
packages), but that would have just put me back to square one :)

I don't use the apt-get command line very often, but it looks like from the
man page you can do something like this:

apt-get install nvidia-glx-185=185.18.36-0ubuntu3

I've never tried it, but the man page says it should work:

"A specific version of a package can be selected for installation by
           following the package name with an equals and the version of the
           package to select. This will cause that version to be located and
           selected for install"

Good luck,

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mythtv.org/pipermail/mythtv-users/attachments/20091204/e84a7e3e/attachment.htm>

More information about the mythtv-users mailing list