[mythtv-users] Any Asus Aspire Revo Users Out There? SOLVED

Kirk Bocek t004 at kbocek.com
Fri Dec 4 04:08:06 UTC 2009

Patrick Doyle wrote:
> On Thu, Dec 3, 2009 at 6:15 PM, Kirk Bocek <t004 at kbocek.com> wrote:
>> We have a winner! Commenting out the Option "UseEDID" "False" line allows
>> sound to flow out the HDMI port. Jim, Ryan Seacrest will be at your house
>> shortly with an oversize novelty check and a van full of balloons. Many
>> thanks.
>> MythTV is working with the "ALSA:plughw:0,3" syntax.
>> Mplayer is working with "ao=alsa:device=hw=0.3" in the config file.
> Congratulations!
> When I get my motherboard back, I'm planning on creating an
> /etc/asound.conf that contains:
> pcm.!default {
>         type hw
>         card <the card number you worked out above>
>         device <the device number you worked out above>
> }
>>From my understanding of http://alsa.opensrc.org/index.php/DigitalOut,
> that should set the default ALSA device to my HDMI port (card 1,
> device 3 in my case, card 0, device 3 in your case).  I'd be
> interested in learning if you tried that and if it allowed you to use
> the default device in MythTV and Mplayer.
> Of course, if you don't feel like messing with something that's
> working, I understand.  I'll find out myself in a couple of weeks.

Yes, indeed, that does work.

I've read various postings that suggest *not* using /etc/asound.conf or 
.asoundrc so that's the route I'm planning on going. This seems like another 
level of indirection that will be confusing when I need to troubleshoot this 
host in two years and have forgotten just what the heck I set up.

I created your /etc/asound.conf and restarted the front end. I reset the sound 
device to "ALSA:default" but left the passthrough settings off (due to the 
monitor I'm using.) Recordings played just fine. I did not reconfigure and 
test mplayer, but I'm sure it would work.

More information about the mythtv-users mailing list