[mythtv-users] Implementing HD-PVR IR Blaster

Bobby Schwartz rschwartz at lastar.com
Tue Dec 1 15:28:56 UTC 2009

> >> If you boot the live image, and the hdpvr is connected and powered
> on,
> >> its driver should auto-load, but you'll still have to manually
> > modprobe
> >> lirc_zilog. After you do that, take a look at dmesg to see if
> >> lirc_zilog claims to have found anything.
> >
> > Well I got around to this yesterday.  I did have to manually
> > lirc_zilog.  It puked on the screen.  See /var/log/messages excerpt
> > below.  I tried first loading the module THEN connecting USB and
> > connecting USB then loading the module.  Both resulted in the same
> > error.  It appears that lirc_zilog finds the chip but errors trying
> to
> > request IR blaster firmware.  I installed the PVR on a Windows
> to
> > update its firmware but I've never used the IR blaster in Windows.
> > Something definitely seems to be missing from the Ubuntu side,
> however
> > the Fedora side isn't working either.
> ...
> > Nov 29 22:59:16 localhost kernel: Zilog/Hauppauge i2c IR 6-0071:
> > firmware: requesting haup-ir-blaster.bin
> > Nov 29 22:59:17 localhost kernel: lirc_zilog: firmware
> > haup-ir-blaster.bin not available (-2)
> Yeah, you're missing /lib/firmware/haup-ir-blaster.bin, has to be
> manually added to the system. Forgot to explicitly mention that part,
> sorry. Google knows where to find it.

I retrieved the firmware last night.  I'm back in Ubuntu land now.
Fedora was able to pick up the zilog chip but Ubuntu still doesn't.  The
zilog module initializes then it just kinda sits there and looks at me.
I picked apart the HD-PVR V4L and Lirc drivers trying to find what's
broken.  It looks like the ir_probe() method in lirc_zilog.c never runs.
Conversely by watching dmesg I can see it runs after the init method in
Fedora.  As best I can tell something deeper in lirc is responsible for
calling that.  I'm not sure where to look next.

More information about the mythtv-users mailing list